3

I've got an OpenVPN server to access our infrastructure remotely. All internal infrastructure is assigned a DNS name in the form SERVER_NAME.my.company.domain. When on site the the DHCP suffix is set to "my.company.domain" through DHCP option 15. I've tried to do the same through OpenVPN but it doesn't seem to work.

My server configuration has the following:

push "dhcp-option DOMAIN my.company.domain"
push "dhcp-option DNS 10.4.0.21"
push "dhcp-option DNS 10.4.0.22"

When connecting through OpenVPN Connect on both Mac and Windows the search domain is listed correctly in the log file. DNS servers are pushed correctly as I can access infrastructure through their full DNS name, however when I use only SERVER_NAME without the suffix I'm unable to access anything.

3 Answers 3

5

I ran across this problem today. This condition is discussed here for further reference: Open VPN Community Wiki and Tracker

Modify:

server.conf

push "dhcp-option ADAPTER_DOMAIN_SUFFIX <SEARCH_DOMAIN>"

or

client.conf

dhcp-option ADAPTER_DOMAIN_SUFFIX <SEARCH_DOMAIN>
1
  • 1
    for OpenVPN 2.x use DOMAIN-SEARCH. Probably it will be supportedd in 3.x at some point too. Commented Sep 22, 2022 at 16:33
0

The correct dhcp option in your case would be DOMAIN-SEARCH (119) instead of DOMAIN (15) because option 15 is the domain that the client should add to its own hostname while option 119 is the DNS domain search list. See IANA's Dynamic Host Configuration Protocol (DHCP) and Bootstrap Protocol (BOOTP) Parameters list for details.

It looks like OpenVPN does not support dhcp option 119 according to ticket #1209

2
  • I was able to get option 15 working in all clients I've tested but OpenVPN Connect so I think it's a client limitation/bug. Commented Mar 19, 2021 at 0:57
  • The names of dhcp-option do not map to the options defined in the DHCP option list, but rather to the internal OpenVPN names. The OpenVPN docs says to use DOMAIN for the connection specific DNS suffix
    – Ferrybig
    Commented Jan 14, 2022 at 21:37
0

This seems to be a limitation with the OpenVPN Connect client on both Windows and macOS. I have tried importing the same configuration using the following clients with success:

  • OpenVPN GUI
  • tunXten
  • Viscosity
  • Tunnelblick

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .