2

I am new to this forum. I need to update my exchange 2013 because of the recent microsoft vulnerability and also because it needs to be updated for the migration to office 365. My exchange is 2013 and it is version 15 Build is 1395.4 . I have a strange issue where I download CU23 to the exchange server. I extract the files into a separate folder. I then run the setup.exe in the extracted folder. What happens next is puzzling. I get a message that it is being initialized and then I get the following screen that I have attached below. I am not sure why but this is what I keep getting. next is greyed out and I cant do anything with the options I am presented. Some things I tried:

-I ran it using admin credentials

-I opened it as an administrator

-I have domain admin, schema admin and exchange organization admin permissions on the user that is opening this file

-I do have the latest pre requisites as I get asked to repair or uninstall them when I try installing

This upgrade is something that needs to happen for the migration project and for security reasons. Any help would be appreciated. Thanks enter image description here

1
1

What is the version of your .Net framework? If you upgrade exchange 2013 to CU23, you should install .Net framework 4.8 then to upgrade to CU23.

Could you download the exchange 2013 cu23 install file in microsoft blog and check if this issue continues?

As Vick Vega has replied above, you could follow the guidance and run install exe again.

0

Your problem could be the .Net Framwork version, but this is tricky to do - I just finished it a few weeks ago (17 to 23).

The problem is the compatibility between .Net Framework versions - see the MS Exchange Compatibility Matrix for Exchange 2013. CU 15 is supporting only up to .Net 4.6.2. So you cannot install Cu23 (becaus this is not supporting .Net 4.6.2) and you cannot install 4.8 because CU15 is not supporting this one.

So you have two options:

  • You make sure you have .Net 4.6.2, the highest supported verison of you Exchange. You update your Cu15 to CU20, both support .Net 4.6.2. Then you install .Net 4.7.1, then you can upgrade to CU22, then install .Net 4.7.2, then you can install CU23. Problem is to get old CU packages, they are not available by Microsoft officialy.
  • Especially if you have multiple Exchange servers, this will take a long time. One way to go directly to CU23 is what I did: completly disable all exchange services - set the Start Type to disable. Then you can install the most current .Net, set the services to automatic, and after that you can install the most current CU, reboot and it should work. There is even somewhere a Microsoft post that is explaining this, I did not find it now. But it worked for me from 17 to 23.

EDIT:

Sitting in an Exchange Training at the moment, and learnt something new: when installing a CU, Exchange will try to check the Certificate Revocationn Lists (CRL) website to check the code signing certificates. It this is not possible, this may cause errors or the installer to get stuck. So either make sure that you have internet connection or, according to the handbook, "turn off the Check for publisher's certificate revocation option on the server that you are upgrading".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.