I just transfered my site from Media Temple's (gs) server to the (dv) server. The transfers went fine.

What went wrong is that I can't access my site through the regular domain anymore.

What's happening is that I can visit the site http://thinkpanda.com, not through the normal domain but by prepending a subdomain http://anythingatall.thinkpanda.com. http://www.thinkpanda.com doesn't work

I think its because when was when I pointed my domain to the new server, I forgot that I also had sub-domains that were still point to the old one. It actually didn't occur to me that this would cause a problem, and maybe that isn't the reason at all. I ended up removing the sub-domains. However, the problem wasn't solved.

I googled and tried "get" in Terminal and its hitting the right server (the dv).

What went wrong and how do I fix this? I need to fix this ASAP!


It might be a DNS caching issue. Your computer might have the IP for the old host cached from when you hit those domains before, and when you try subdomains you've never used before it has to resolve them fresh so it gets the new IP. I would recommend trying to hit the new site from a computer you've never hit them before, preferably on a different network (like take a laptop to Starbucks or Panera).

As further evidence, when I got to the http://thinkpanda.com/ url, I see a page that looks correct.

  • I get an empty page -- most likely its what Paul said - you're waiting on DNS – Erik Jan 24 '10 at 13:03
  • Thanks for the quick response (I've been up all nite trying to solve this, and its 8am now). Its good to know that atleast someone can see the site normally. I'll try from another computer and see if it works. Essentially I just have to wait for the whole DNS propagation now? I was just really confused because of how the subdomains go the site just fine. – 828 Jan 24 '10 at 13:16
  • @828 Assuming it's a DNS issue, you don't have to wait for "propagation"; you have to wait for the TTLs on various recursive resolvers' records of you to expire, so that they will be pulled again from the authoritative server. – phoebus Jan 24 '10 at 16:48
  • thinkpanda.com has a TTL of 300 (five minutes), so that's quite unlikely. – Fahad Sadah Jan 24 '10 at 17:30
  • @fahadsadah Then it's likely not just a DNS "propagation" issue. I'm just trying to point out that the term is incorrect. – phoebus Jan 24 '10 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.