I have a number of rails applications deployed from an ubuntu slice from slicehost. I have multiple domains hosted from the slice using virtual hosts. I have noticed for years that subdomains always load slower than fully qualified domains. Is there something I can do to speed this up? I have even tried declaring the subdomains as A records rather than CNAME, because from my understanding, a CNAME record does 2 lookups rather than the 1 that an A record does.

Here's an example:

allbouttexas.com (loads quickly)


dev.allbouttexas.com (takes 5-10 seconds)

Thanks in advance.

migrated from stackoverflow.com Jan 25 '10 at 6:12

This question came from our site for professional and enthusiast programmers.


Its loaded very quickly here, so its your internet or your dns issue.

You could try testing at just-ping.com

  • Thanks for the response. I have tested this with other subdomains of mine and the subdomains continue to load slower. Any ideas? Are you sure you tried dev.allbouttexas.com? versus allbouttexas.com? The URL with the subdomain seems to load much slower (coming from my network and outside my network). – Josh Jan 25 '10 at 2:40
  • Hi, Please take a look just-ping.com results above for dev.allbouttexas.com. its pinging from many countries, most of them are under 500 ms response. – S.Mark Jan 25 '10 at 2:57
  • Yes, I saw it. The thing is, I'm just going by eye balling it. If I load an FQDN site (without a subdomain) it usually takes 1 second. If I load a site with a subdomain it take 7-10 seconds on average. This is consistent across all apps I develop/manage, which is about 10 of them. – Josh Jan 25 '10 at 3:12
  • Yes, its strange, Have you tried with different PC with in your same network? I guess its DNS issue or some virus scan might be doing some checks, but 7-10 seconds is pretty slow though. btw, I am going to participate in voting this thread to move to serverfault.com, there you could get more response on such things. – S.Mark Jan 25 '10 at 3:40
  • @OP: Came up in the same time for me, a second or two. I did a "hard" refresh (Ctrl+F5) on dev (to minimize caching benefits), and it was the same. Like S.Mark, I suspect a local issue -- DNS problem at your end or similar. – T.J. Crowder Jan 25 '10 at 7:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.