0

So i installed Etherpad-Lite on an (Ubuntu 20.04) VM on our server.
I also installed Nginx and set up the following vhost.
In my sites-available there are 2 entries: default and etherpad.conf
This is my etherpad.conf

upstream etherpad {
   server localhost:9001;
   keepalive 32;
}

server {
   listen 80;
   server_name example.etherpad.at;

   location / {
       client_max_body_size 50M;
       proxy_set_header X-Real-IP $remote_addr;
       proxy_http_version 1.1;
       proxy_pass http://etherpad;
   }
}

And this is my settings.json for Etherpad (ip set to 127.0.0.1)

   * IP and port which Etherpad should bind at.
   *
   * Binding to a Unix socket is also supported: just use an empty string for
   * the ip, and put the full path to the socket in the port parameter.
   *
   * EXAMPLE USING UNIX SOCKET:
   *    "ip": "",                             // <-- has to be an empty string
   *    "port" : "/somepath/etherpad.socket", // <-- path to a Unix socket
   */
  "ip": "127.0.0.1",
  "port": 9001,

I've also added a DNS entry in my host file and in my Firewall, just for testing purpose.

But when i go to the domain or the IP, i get an "This website is not reachable.....right dns...proxy...)
Ultimate when i set the ip of etherpad to something else i always get: Error: listen EADDRNOTAVAIL

What am i doing wrong?

1 Answer 1

0

So apparently i had everything configured right but only after a reinstallation it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.