2

We are using VMware Workstation 7 running on a Windows 7 Pro system. When trying to update the VMware Tools, either when starting a VM or manually using edit>preferences>updates, we receive a message that says "There was a problem updating a software component. Try again later and if the problem persists, contact VMware Support or your system administrator." Has anyone else ran into this issue and, if so, how were you able to resolve it? The guest VM is a Windows XP Pro system that was converted over from a physical computer.

1
  • 1
    Have you tried contacting VMware support, as the message says? Jan 25, 2010 at 13:27

2 Answers 2

2

I had similar problem with vms migrated from vmware server to esxi. Uninstalling old vmware tools with 'add/remove programd' and installing new version from windows.iso solved the problem.

0

I found the problem by the log file /var/log/vmware-install

...
ImportError: libncursesw.so.5: cannot open shared object file: No such file or directory

May be my Linux system was updated to the 6th version of the ncurses libs, so I was made link from 5 to 6 libs:

ln -s /usr/lib64/libncursesw.so.6 /usr/lib64/libncursesw.so.5

And then successfully install the VMware Tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy