I've got a CentOS 5.2 server that I'm trying to get set up as a development environment. As part of this, I planned to install VMWare Server 2 and set up several virtual development servers.

I've got as far as installing VMWare Server 2 but access to the remote control panel is only working intermittently.

If I access it through Firefox at it usually says either:

"Connection intterupted: connection was reset before the page loaded"


"Firefox can't establish a connection to the server at"

But every now and then it lets me in and I'll manage a few clicks in the web UI before it kicks me out with the following error:

"The server could not complete a request (HTTP 0 ). The server encountered an unexpected condition that prevented it from fulfilling the request. If this problem persists, please contact your system administrator."

I've done all the updates available in CentOS except one OpenOffice one that is causing a conflict, and I re-ran wmware-config.pl after updating the kernel. Though I went with all the defaults as I don't really know what I'm doing! I've since rebooted and nothing changed.

I've also tried accessing the control panel remotely from another machine in the network and the results are the same.

Does anyone have any ideas what might be causing this and how I can resolve it?

I'm afraid I'm a developer playing at sys-admin, so I may be missing something obvious!

Many thanks



I have now reinstalled both the operating system and VMWare and I'm still getting the same issue. I wonder if it's a result of the settings I'm putting in on the config.pl script..?

4 Answers 4


VMWare Server's 8333 console is a bit flaky to be honest, there are other questions regarding this on SF and elsewhere - basically you get what you pay for - and it's free :)


I have had the same kind of issue with VMWare Server 2.0, except for me, the installation was on a remote server. In my case, when this happens, I need to restart the management service via:

/etc/init.d/vmware-mgmt restart.

This does not restart any of the other pieces of your VM architecture (network, VMs, etc...), so your testing machines won't be affected.

If this does not provide a solution for you, I suggest installing VMWare Server 1.0.10, which is still available, although frustratingly sequestered from VMWare's search utility here: http://downloads.vmware.com/d/info/datacenter_downloads/vmware_server/1_0.

  • The restart command did not make a difference, but there was a failure on the restart command: [root@localhost ~]# /etc/init.d/vmware-mgmt restart Stopping VMware management services: VMware Virtual Infrastructure Web Access VMware Server Host Agent [FAILED] Starting VMware management services: VMware Server Host Agent (background) [ OK ] VMware Virtual Infrastructure Web Access [root@localhost ~]#
    – PeteWilliams
    Feb 15, 2010 at 11:17
  • TBH, VMWare Server 2.0 has always been a little too unstable for me. Try searching for the error message. If you recently upgraded your kernel, remember to run /usr/bin/vmware-config-tools.pl to reconfigure the VMWare kernel modules; that could be causing the problem. If you still can't get no sssatisfaction, try the older version of VMWare Server. I don't know for sure if the VM virtual hardware is compatible, but conversion shouldn't be too difficult.
    – Joe
    Feb 15, 2010 at 21:00

If your browser is using SSL 3, reconfigure it to use SSL 2, or downgrade the browser. The VM admin and console requires SSL 2.

  • I've tried that, but it didn't make a difference. Thanks anyway.
    – PeteWilliams
    Feb 15, 2010 at 11:15

I've had numerous problems with the web ui in server 2 also. I have found that while I could rarely connect with Firefox, I often have a better than 50% chance with IE.

I just remembered I read this recently, so if you have access to vsphere client, you can hack it to manage your server2 vms.

You must log in to answer this question.