0

It was possible to add net.ipv4.icmp_echo_ignore_all = 1 to /etc/sysctl.conf and reload with sysctl -p.

This does work for me on Ubuntu 20.04.

But after a reboot, the machine responds to ICMP requests again.

Why is that, and is there a fix?

Thanks in advance.

2
  • What is the value of net.ipv4.icmp_echo_ignore_all after the reboot? Is systemd-sysctl.service enabled; what does systemctl status systemd-sysctl.service tell you? – berndbausch May 3 at 8:00
  • Just set up a new server, disabled ping, all was fine. After enabling UFW the ICMP responses came again. So, you are only affected if using UFW. Then you have to disable ICMP responses in the UFW rules. – Howard May 27 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.