Over the weekend someone attempted to upgrade Windows Server 2003 to 2008 on one of our machines. Not sure what happened, but it didn't work and now when booting up after the little green bars, the screen goes black, there is a white cursor, and nothing ever happens. If I start in SafeMode, I get some kind of "Cannot complete installation in SafeMode, please restart" error, so nothing doing there.

I figured I'd try a fresh install, but I cannot get either a CD with the ISO or a bootable USB flashdrive to work. I have tested both the CD & flashdrive on another machine and they work fine. On this machine, if I try to boot it from the boot order it says no bootable media found, if I try to directly boot from a boot menu, the USB drive method gets stuck with a blinking cursor and nothing happens, while the CD will take me to a 'Start Windows in SafeMode` prompt. I tried to boot a linux disc to rule out the CD drive and that worked fine. Any ideas?

  • Can you specify if it's 32 or 64 bit ? If 64, can the server handle it ? I hope the guy didn't try to upgrade from a 32 bit 2003 server to a 64 bit 2008, which is not supported Feb 3, 2010 at 14:56

2 Answers 2


I know this is a really old thread but I had the same problem and searched all over and couldn't find the solution. I finally remembered that the known issues article for the upgrade said that if you had a second hard drive you had to disconnect it for the upgrade to complete successfully. I powered the server off, disconnected the second hard drive, and then the upgrade completed successfully.


I know that this is a very old question but I just found out that if the server has an SSL certificate in IIS, this might happen.

So, removing the IIS SSL certificate would fix it (at least for me).

This is based on my on practical experience, and I got the idea from: http://blogs.technet.com/b/mrsnrub/archive/2009/11/19/http-sys-cryptographic-services-lsass-exe-deadlock.aspx


Good luck to whoever is still dealing with Win2003 at this day and age (like myself).

  • Note: you might need to load the system hive offline to add the Depedency to the HTTP service after running the upgrade (support.microsoft.com/en-us/kb/2379016).
    – rufo
    Jan 29, 2016 at 17:23
  • ... and it might need an user to try to RDP to it before it actually starts working.
    – rufo
    Jan 29, 2016 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.