0

I've just setup a Ubuntu droplet on Digital Ocean, and I'm having trouble pointing my subdomain to the droplet IP. The main domain is working just fine (it points to a different droplet). When I set the A record for the subdomain (pointing to the correct IP) and try to access the website, I get ERR_CONNECTION_REFUSED, although DNS propagation seems fine (I checked it at DNS Checker). Then I set the NS record for the same subdomain, pointing to the same nameservers which the main domain is pointed to, and now the error on the page is DNS_PROBE_FINISHED_NXDOMAIN. Also, when I set the NS record, the A record went crazy according to DNS Checker. I'm sorry, I'm really confused, this is the first time I've done this. This is how the records are set currently

1

Your initial configuration that just had an A record for app.example.com pointing to the new droplet IP was correct. The additional NS records you added were unnecessary.

The connection refused message you got with the initial configuration likely points to a non-DNS related config issue on your droplet unless you typo'd the IP address in the A record. Check firewalls. Check that the web server is running and on the port you expect.

2
  • What should I check for on the firewall? I'm really lost, sorry... – Marcelo Silveira May 6 at 16:46
  • Check that port 80/443 are allowed. – Ryan Bolger May 6 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.