We have a Subversion repository on Windows Server 2003 and would like to move it to a new server running Server 2008 R2 64 bit. The new server has 8 gb of ram.

I was hoping to dump and load the entire repository since it's currently in a pre 1.5 format. The repository has just over 20,000 revisions. On revision 12900 the svnadmin process runs out of memory no matter how I try to import that version.

I've tried loading the entire thing from one large dump file. I've tried piping the entire dump directly into the load. I've also tried doing smaller revision sets in both ways. And even just trying this one revision by itself.

The process gets up to around 1998 mb used in task manager before it terminates with this error:

D:\Repositories\svnrepos>svnadmin load ./ < c:\Backup\svn_12900.dmp <<< Started new transaction, based on original revision 12900 * editing path : .../Bld/Installers ... done. * editing path : .../Bld/Installers/xyxSetup.exe ... done. * editing path : .../Installers/xyxyWebSetup.exe ... done. * editing path : .../Bld/Src ...Out of memory - terminating application.

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

I've checked the log for this revision number and it was actually just committing an auto build, so the installers which import fine and then just version numbers in AssemblyInfo.cs files when it fails.

I'm not sure what else I should try?

  • What's the filesize of svn_12900.dmp? – Alex Holst Jan 26 '10 at 6:30
  • With the incremental flag it's only like 5.8 mb, but the full is almost 2 gb. – Reg Jan 29 '10 at 2:22

Using the 32-bit version of svn on a 64-bit Windows means svn can only allocate 2GB of memory. Get a 64-bit build of subversion.

I no longer remember the algorithm for svn's stream load, but it may think you have 8GB available and terminates when it itself cannot manage more than 2GB.

| improve this answer | |
  • Does anyone publish a 64-bit Windows version? I sure can't find it if anyone is doing that. – Reg Jan 28 '10 at 19:55
  • You may have to build your own version. I don't recall if TortoiseSVN includes the administrative svn commands. Try installing their 64-bit version and see what happens. – Alex Holst Jan 29 '10 at 8:46

I would recommend mailing this question to users@subversion.apache.org, as this list contains a lot of subversion system administrators. At least a few of them have probably seen this issue before.

| improve this answer | |

try svn-kit. it's java port of subversion.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy