0

I am trying to send main with Postfix and Dovecot but I am always getting:

May 10 15:13:41 3b15 postfix/smtp[21418]: connect to gmail-smtp-in.l.google.com[64.233.162.27]:25: Connection timed out
May 10 15:13:41 3b15 postfix/smtp[21420]: connect to gmail-smtp-in.l.google.com[2a00:1450:4010:c05::1a]:25: Connection timed out
May 10 15:13:41 3b15 postfix/smtp[21421]: connect to gmail-smtp-in.l.google.com[64.233.162.27]:25: Connection timed out
May 10 15:13:53 3b15 postfix/smtp[21508]: connect to gmail-smtp-in.l.google.com[2a00:1450:4010:c05::1a]:25: Connection timed out

I am on Ubuntu 18.04 with Postfix mail_version = 3.3.0 and Dovecot 2.3.14 (cee3cbc0d), I changed the port for Postfix to 2525 and when I run telnet localhost 2525 I am getting:

Trying ::1...
Connected to localhost.
Escape character is '^]'.
220 server ESMTP Postfix (Ubuntu)

But when I run the same command with my domain instead of localhost I am getting:

Trying 2606:4700:3033::ac43:c709...
Trying 2606:4700:3032::6815:2c6e...
Trying 104.21.44.110...

And nothing happens. Any idea might the issue be?

When I run status checks on postfix and dovecot I am getting success messages:

postfix.service - Postfix Mail Transport Agent
   Loaded: loaded (/lib/systemd/system/postfix.service; enabled; vendor preset: enabled)
   Active: active (exited) since Mon 2021-05-10 15:12:41 EEST; 15min ago
  Process: 21397 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 21397 (code=exited, status=0/SUCCESS)

May 10 15:12:41 server systemd[1]: Starting Postfix Mail Transport Agent...
May 10 15:12:41 server systemd[1]: Started Postfix Mail Transport Agent.


dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-05-10 14:50:14 EEST; 38min ago
     Docs: man:dovecot(1)
           https://doc.dovecot.org/
  Process: 20314 ExecStop=/usr/bin/doveadm stop (code=exited, status=0/SUCCESS)
 Main PID: 20317 (dovecot)
    Tasks: 5 (limit: 2359)
   CGroup: /system.slice/dovecot.service
           ├─20317 /usr/sbin/dovecot -F
           ├─20318 dovecot/anvil
           ├─20319 dovecot/log
           ├─20320 dovecot/config
           └─21436 dovecot/stats

May 10 14:50:14 server systemd[1]: Stopped Dovecot IMAP/POP3 email server.
May 10 14:50:14 server systemd[1]: Started Dovecot IMAP/POP3 email server.
0

First thing that probably you have blocked port 25 for outgoing connection, this is a standard for most home internet, to avoid spam.

Second, you website is hidden using CloudFlare proxy, so you connection is pointing to their servers not you one. To force connect locally add a proper entry into 'hosts' file point to your local ip to this will then work locally for that box.

Thanks,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.