1

Ok. That's STRANGE. Similar issues: enter link description here

We are running other ESXi 7.0 Update 2a servers but now we began setting a few from scratch and guess what? The login credentials STOP WORKING ALTOGETHER randomly and persistently even in the middle of a f**** session.

We've kept ordering additional KVM hours in the datacenter reinstalling ESXi just for the loop to continue.

This holds for SSH/Web AND remote Workstation 16 connections.

Ideas?

The servers that were upgraded to 7.0a2 work FINE. The new ones with ESXi installed from an ISO (downloaded directly from vmWare) break even if the password is the same as on the old ones (just to rule out some inconsistent rules-processing among access interfaces)

To rule out the possibility of us having broken keyboards or something we were literally copy pasting passwords from plaintext into ssh and web-terminals. We've triple checked keyboard layouts and stuff. wtf?

UPDATE:: AFTER restarting the servers. The (same) passwords work at random. Some crazy s*** going on here. We've been monitoring traffic no suspicious 'attacks' that would make accounts go into lockdown etc.

Update 2: The only solution which seems to work for now is to physically restart the servers after which the login works... for a couple of minutes. There do not seem to be any relevant entries in logs.

Update 3: it's getting ridiculous. We've found another 'work-around'. Instead of hardware hot-resetting the entire f*** server with all the VMs within, we keep one web-session open all the time and when sh** hits the fan we just.. change password to the same one in web-ui. go figure. that makes things work for more ..minutes. when web-ui disconnects. gotta reset servers.

2
  • The login credentials STOP WORKING ALTOGETHER randomly and persistently even in the middle of a f**** session - What does that mean, exactly? What happens? What are the symptoms? – joeqwerty May 11 at 15:02
  • ESXi rejects login credentials saying password is invalid. SSH, WEB-UI, everything. Couple of servers official ISO. Also true for locally spawned installer we access over KVM. Sounds crazy but it's true. – Vega4 May 11 at 15:04
0

Yes is some kind of strange, one trick that has worked for me is holding and pressing shift while clicking on the login button, it has worked for me, if you have access to the ESXi via KVM try to restart the remote agents, this also works

2
  • Are the Management interfaces of these hosts connected to the Internet, i mean publicly available? If yes then there is a high probability that some rogue attackers try to log in using random passwords. After too many failed attempts the root account will be locked out, and you will receive "invalid login" errors even when using the correct password. Only at the console the correct password will still be accepted. In this scenario you can unlock the root account with the command "pam_tally2 --user root --reset" at the console. – VFrontDe May 12 at 11:35
  • If the hosts are on the internet then you must make sure that you limit access to them using the builtin firewall (or other external firewalling). Limit at least access to ports 443 and 22. – VFrontDe May 12 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.