2

I run these commands to install DNS server dependencies on openSUSE Tumbleweed:

sudo zypper in -t pattern dhcp_dns_server
sudo systemctl enable named.service
sudo systemctl start named.service

To configure the DNS server, I'm trying YAST2 following this documentation:

sudo yast2 dns-server

I intend to configure example.com domain zone with IP address 1.2.3.4.

What I did

I have a DNS zone of master type:

Zone: master

My NS Records tab is:

NS Records tab

My Records tab is:

Records tab

Problem

However, saving the configuration runs into a problem:

Warning

Saving the configuration failed. Change the settings?

Problem

I couldn't figure it out. Can anyone help?

Update

Suggested by @JiriB I ran these commands and reconfigured the DNS server. But the observation is the same as before:

sudo systemctl revert named.service
sudo rpm  -qV bind
sudo cp /etc/named.conf.YaST-backup /etc/named.conf
sudo yast2 dns-server
5
  • 1
    Why do you start and enable named manually. Shouldn't YAST take care about it? I would start systemctl revert named.service, rpm -qV bind, then i would restore /etc/named.conf.YaST-backup, and start with yast dns-server again. – Jiri B May 12 at 12:46
  • @JiriB Thanks =) Let me try! – user4838962 May 12 at 12:51
  • @JiriB It didn't work! Updated the post! – user4838962 May 12 at 13:22
  • 1
    Then you must reveal more info. – Jiri B May 12 at 13:28
  • @JiriB Right! The steps in the post are all I do. Let me see if I can provide more info =) – user4838962 May 12 at 13:30
1

The problem of:

Warning

Saving the configuration failed. Change the settings?

Got resolved by stopping the named service before launching YAST2:

sudo systemctl stop named.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.