I have an Issue with connecting to Windows 7 via RDP. I can open an RDP Session, but regardless of any settings, the response times are really long. This in particular is the case when opening a web page in a browser. I've tried IE, Firefox and Google Chrome.

I also use RDP connection to a Windows 2008 Server from the same client machine, and the speed is very normal with all features turned on. We have Gigabit Ethernet here. So I think it can not be the client's fault.

What concerns Windows 7 Machine, I've tried shutting all the graphic features off and turning the color levels to 256 colors. Result - the same.

If I work locally on the machine - I can not see any lags.

What else have I tried:

  • Using old RDP 5 Client from Microsoft
  • Setting network autotuninglevel as seen here

Do You have some ideas?

Thanks in advance!

Update the problem seems to be with rendering window contents. All the window borders and panes are rendered pretty quickly, but the content shows up very slowly. Also mouse movements are recognized by the Win 7 box only after some period.

Are there some hidden settings in the RDP, where one could turn some advanced features off or turn some caching on? I use Bitmap Caching, but this apparently doesn't help.

14 Answers 14


I had the same problem, and downloading and installing the latest drivers for the Network Interface Card from the manufacturer's site solved it.

Turning off the offload is apparently not a "solution," but covering up a problem because your remote connection is supposed to work fine with offloading on.

But just in case your problem cannot be solved with latest drivers, I am linking all the pages I found on the topic.



  • 1
    It looks like the VMWare drivers were the problem and not the RDP or Windows. Sorry for not providing this detail. Did not think of it first.
    – Pavlo
    Feb 3, 2012 at 14:44

I have the same issue. Mine sometimes locks up altogether and it is definately the same problem with complex window contents drawing slowly. Opening IE sometimes hangs it completely.

I promise to return and post an answer. All threads on this on the web go dead!


For me, this was a case of a bad (default MS) graphics driver for the IBM eServer 326m I'm running. Since going to Win 2008 it needed repointing to the driver.

In the unlikely event your server also has an ATI ES1000:



This actually didn't solve it. Scrolling in IE is not a good test. It seems that it doesn't like drawing the Windows 2008 MMC snap-ins and the entire connection hangs when there are too many open.



DWORD, DisableTaskOffload. Set its value to 1.

Oh yes!!!!!

  • +.5 for your commitment and +.5 for your commenting troubles.
    – squircle
    May 28, 2010 at 11:03
  • If this fix works, remember to re-enable that TCP window scaling feature: netsh interface tcp set global autotuninglevel=normal; netsh interface tcp set global rss=enabled May 28, 2010 at 11:36
  • Also, I notice that somehow the DisableTaskOffload gets reset to 255 on my server. Lord knows what's doing that! May 28, 2010 at 14:02
  • I tried all of the things in this discussion. After rebooting (which I was only able to remoting in via LogMeIn), it seemed back to normal, but after a day, it was back to being unusable again, and the DisableTaskOffload setting was still 1. Really frustrating. Oddly, the RDP via LogMeIn has no such issues (but I can't use all my monitors, so not a good long-term solution).
    – sydneyos
    Jul 16, 2014 at 20:34

Change to the basic mouse cursor theme. This has really helped me, although it still doesn't feel quite as fast as XP.


Try running this command on the Win7 box.

netsh interface tcp set global autotuninglevel=disabled

The latest drivers on asrock's site were pretty old. I found drivers on Realtek's site. After installing these drivers (v. 7.053) the problem cleared up.


Try this it worked for me

Here is what you need to do if you have the same issue:

  • Run a command prompt (cmd.exe) as an Administrator
  • Type: netsh interface tcp set global autotuninglevel=disabled Disable the autotunning feature in Vista completely, and fit and lock the RWIN receive window to default value 65536 bytes.

If you want to to re-enable it: - Type: netsh interface tcp set global autotuninglevel=normal

In some cases you may need to use this command in addition to the above, but I didn't have to: - Type: netsh interface tcp set global rss=disabled

Update! This command makes your network connection EVEN FASTER Type: netsh interface tcp set global autotuninglevel=highlyrestricted thanks Syedk

  • could you clarify whether this command is meant to be run on the remote or local machine?
    – sydneyos
    Jul 16, 2014 at 20:35

Dodgy network link to the Windows 7 box? Have you tried using ping and tracert to both the Windows 7 box and the 2008 server to check for any inconsistencies?

  • Tried that. Pings are normal. All the three boxes are in the same subnet and are connected to the same switch.
    – Pavlo
    Jan 27, 2010 at 0:37

Whats in these windows? Animation or video? I find that once you encounter anything animated over a WAN RDP, unless you have a 10+ mbps both ways, then you're going to get bad performance no matter what. Supposedly, the new RDP technology as part of Win7 SP1 will help mitigate this in the near future.

When I use a browser over RDP, I tend to use flashblock and disable gif animations to get around this.


I was finally able to figure this out.

I was having very similar issues using RDP that was solved by disabling any sort of Offloading on the network adapter configuration properties (in my case, this was five different settings options).

Once I did that, my issues went away immediately.


Had similar problem. RDP would freeze and be choppy when connecting from Windows 7 to Server 2003, had absolutely no problems with XP or Windows 2000 though. Server has ATI ES1000 video card and I was suspecting it was causing problems.

However after playing around and trying different things - it turned out to be Windows Firewall on the server. Even though the service was disabled it still needed exception rule to allow RDP. Enabled - went to exceptions tab - allowed RDP - disabled again.

Hope it helps someone.


you can invoke local group policy editor using gpedit.msc administrative templates->windows components->remote desktop services and do certain configurations like 1 session per user and can also configure like the session should get disconnected if the user stays idle for a long time. this might apparently increase the performance of the system.


Try enabling RDP 8. Apparently it's not enough to just have it on your box... you have to manually enable it. In your Local Group Policy Editor:

Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\Enable Remote Desktop Protocol 8.0

Set to “Enabled”

Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections\Select RDP Transport Protocols”

Set to “Enabled” and “Use both UDP and TCP”

More info here: http://microsoftplatform.blogspot.nl/2013/04/microsoft-rdv-team-get-best-rdp-80.html

Even more tips here: https://social.technet.microsoft.com/Forums/office/en-US/6ed6500d-33f7-4f0c-89fb-8d8442c7a229/extremely-slow-rdp-session-solved?forum=winserverTS


After installing 3,6GB of updates, (avoiding update of NIC), RDP connection issued very bad graphics and working performances (there was no way to do work remotely).

The mouse has a time lag and ghost all the time, the connection was trying to be established from 3 different RDP versions (3 different OS versions) and on the Lenovo-PC side it was on version 6.1.

Every time issue was the same.

  1. RDP version update from 6.1 to 8.0 did not fix the problem.
  2. "netsh int tcp set global chimney=disabled", did not fix the problem.
  3. Various graphic settings changes did not fix the problem.
  4. Downgrade and replace of Graphic driver did not fix the problem.
  5. Changing Group Policy for RDP did not fix the problem.
  6. Removing all the installed updates did not fix the problem.
  7. Windows performance changes did not fix the problem.
  8. Mouse shadow and speed changes did not fix the problem.

The solution was to install the NIC driver update from Microsoft


I had a lot of lag on the mouse movements on a win2012 server. It really helped disabling the mouse pointer shadow.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .