2

I have a server that won't respond to pings, but I can remote desktop to it.

The server has two LAN connections. Each has the same subnet mask and default gateway, but separate IP addresses. I'm not sure why there are two LAN connections, but assume that they are needed.

Any idea why the server won't respond to pings (or telnets to any port that isn't remote desktop)?

5

Is windows firewall on, or another firewall?

It might be configured to block all other ports and icmp traffic (pings).

  • Disabling the firewall makes it pingable. Now the question is, how do I fix the issue without disabling the firewall? – John Jan 26 '10 at 15:14
  • (Windows firewall... on Windows Server 2003) I don't see anything in the firewall settings that would block all ports but remote desktop. – John Jan 26 '10 at 15:18
  • I think remote desktop is a default 'exception'. So if you add an exception for ICMP pings should work. I don't ever really use Windows firewall, but I am sure a quick google or technet search will explain it. – Kyle Brandt Jan 26 '10 at 15:22
2

If you are using Windows firewall, you need to allow ICMP ping requests.

This is in the advanced tab of the firewall settings, click on th esetting button in the ICMP section, tick the "Allow incoming echo requests" option.

Allow ping http://img62.yfrog.com/img62/723/screenshot007au.jpg

0

Make sure that Windows Firewall is explicitly set to allow Pings [ICMP], blank/not-set value does not count.

Windows (Defender) Firewall
 -> Inbound Rules
  -> File and Printer Sharing

Right Click and select the first option, Enable Rule (for both v4 and V6 although v4 is the minimum one).enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy