1

i'm trying to launch what should be a simple commercial proxy server. I have bought a subnet of IPs, and I want to make those IPs accessible to some paying customers. These are the base requirements I'm going for:

  1. 1 port to 1 IP, static connection - Done
  2. 1 port/port range to 1 or a few acl auth ips or user auth. - Problems here.

The issue is I'm trying to add the acl to each port individually, unfortunately squid is allowing any single acl access to all ports.

These are the relevant entries in my cfg file:

acl server_one_ip src 40.70.184.218
http_access allow server_one_ip
http_access deny all

http_port 3128 name=port_3128
http_port 3127 name=port_3127

acl port_3128_acl myportname port_3128
acl port_3127_acl myportname port_3127

# just forward traffic, don't use peers (not?)
always_direct deny port_3128_acl server_one_ip
always_direct deny port_3127_acl

never_direct allow port_3128_acl server_one_ip
never_direct allow port_3127_acl

# 3128
cache_peer 207.202.217.26 parent 7823 0 proxy-only default  name=proxy3128
cache_peer_access proxy3128 allow port_3128_acl server_one_ip
cache_peer_access proxy3128 deny all

# 3127 
cache_peer 207.202.211.170 parent 5991 0 proxy-only default  name=proxy3127
cache_peer_access proxy3127 allow port_3127_acl
cache_peer_access proxy3127 deny all

So, to reiterate, everything else works fine. Each port keeps it's external routing static, the issue is I don't know how to add specific acl src lists for each port.

My entire config file if it helps:

#
# Recommended minimum configuration:
#

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed

acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 172.16.0.0/12  # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7       # RFC 4193 local private network range
acl localnet src fe80::/10      # RFC 4291 link-local (directly plugged) machines
acl server_one_ip src 40.70.184.218

acl SSL_ports port 443
acl Safe_ports port 80      # http
acl Safe_ports port 21      # ftp
acl Safe_ports port 443     # https
acl Safe_ports port 70      # gopher
acl Safe_ports port 210     # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280     # http-mgmt
acl Safe_ports port 488     # gss-http
acl Safe_ports port 591     # filemaker
acl Safe_ports port 777     # multiling http
acl CONNECT method CONNECT

#
# Recommended minimum Access Permission configuration:
#

# Only allow cachemgr access from localhost
http_access allow localhost manager
http_access deny manager

# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#

# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost
http_access allow server_one_ip

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 3128 name=port_3128
http_port 3127 name=port_3127

nonhierarchical_direct off

acl port_3128_acl myportname port_3128
acl port_3127_acl myportname port_3127

# just forward traffic, don't use peers (not?)
always_direct deny port_3128_acl server_one_ip
always_direct deny port_3127_acl

never_direct allow port_3128_acl server_one_ip
never_direct allow port_3127_acl

# 3128
cache_peer 207.202.217.26 parent 7823 0 proxy-only default  name=proxy3128
cache_peer_access proxy3128 allow port_3128_acl server_one_ip
cache_peer_access proxy3128 deny all

# 3127 
cache_peer 207.202.211.170 parent 5991 0 proxy-only default  name=proxy3127
cache_peer_access proxy3127 allow port_3127_acl
cache_peer_access proxy3127 deny all


# Uncomment the line below to enable disk caching - path format is /cygdrive/<full path to cache folder>, i.e.
#cache_dir aufs /cygdrive/d/squid/cache 3000 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/cache/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp:       1440    20% 10080
refresh_pattern ^gopher:    1440    0%  1440
refresh_pattern -i (/cgi-bin/|\?) 0 0%  0
refresh_pattern .       0   20% 4320

dns_nameservers 8.8.8.8 208.67.222.222 

max_filedescriptors 3200
5
  • I would suggest making it easier and run 2 copies of squid instead if troubling yourself into a new issue?
    – djdomi
    Jun 8, 2021 at 14:12
  • @djdomi i'm going to need thousands of ports open, so, unfortunately, that's not feasible :(
    – user728874
    Jun 8, 2021 at 16:05
  • then please update your question, it seems currently to be a x and y problem, why you need http port for each customer when afaik you can set users or groups and align them acl to fetch the rules? keep in mind that if the one and only process dies, All your customers are affected at the same time....
    – djdomi
    Jun 8, 2021 at 17:46
  • @djdomi i'm a bit confused on what your advise is. Is there no way to have acl's per port? Is there something wrong with the way I've asked my questions?
    – user728874
    Jun 9, 2021 at 1:11
  • Shortly Said, what are you trying to solve (X and Y Problem) for what is this routing/proxing?
    – djdomi
    Jun 9, 2021 at 4:03

0

You must log in to answer this question.

Browse other questions tagged .