0

I have another machine on my network running avahi-daemon with the default configuration and it's been working fine since the first boot.

On a newer machine, avahi-daemon works only if i set systemctl set-default graphical.target. With multi-user.target the machine boots, avahi starts and then gets a SIGTERM. This is from journalctl | grep avahi:

avahi[4204]: Avahi detected that your currently configured local DNS server serves
avahi[4204]: a domain .local. This is inherently incompatible with Avahi and thus
avahi[4204]: Avahi stopped itself. If you want to use Avahi in this network, please
avahi[4204]: contact your administrator and convince him to use a different DNS domain,
avahi[4204]: since .local should be used exclusively for Zeroconf technology.
avahi[4204]: For more information, see http://avahi.org/wiki/AvahiAndUnicastDotLocal

The workaround I've found is to set AVAHI_DAEMON_DETECT_LOCAL=0 inside /etc/default/avahi-daemon. But this isn't a solution since it's been working in graphical.target.

How can I see what's missing in multi-user.target that messes up avahi's mDNS .local name resolution?


avahi-daemon version:

avahi-daemon/bionic-updates,bionic-security,now 0.7-3.1ubuntu1.2 arm64

nsswitch.conf (default):

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat systemd
group:          compat systemd
shadow:         compat
gshadow:        files

hosts:          files mdns4_minimal [NOTFOUND=return] dns myhostname
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis

avahi-daemon.conf (default)

[server]
#host-name=foo
#domain-name=local
#browse-domains=0pointer.de, zeroconf.org
use-ipv4=yes
use-ipv6=yes
#allow-interfaces=eth0
#deny-interfaces=eth1
#check-response-ttl=no
#use-iff-running=no
#enable-dbus=yes
#disallow-other-stacks=no
#allow-point-to-point=no
#cache-entries-max=4096
#clients-max=4096
#objects-per-client-max=1024
#entries-per-entry-group-max=32
ratelimit-interval-usec=1000000
ratelimit-burst=1000

[wide-area]
enable-wide-area=yes

[publish]
#disable-publishing=no
#disable-user-service-publishing=no
#add-service-cookie=no
#publish-addresses=yes
publish-hinfo=no
publish-workstation=no
#publish-domain=yes
#publish-dns-servers=192.168.50.1, 192.168.50.2
#publish-resolv-conf-dns-servers=yes
#publish-aaaa-on-ipv4=yes
#publish-a-on-ipv6=no

[reflector]
#enable-reflector=no
#reflect-ipv=no

[rlimits]
#rlimit-as=
#rlimit-core=0
#rlimit-data=8388608
#rlimit-fsize=0
#rlimit-nofile=768
#rlimit-stack=8388608
#rlimit-nproc=3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.