0

Problem

On a CentOS Linux (7/8) box with IPv6 and EUI-64 generation mode configured, NetworkManager says that the address generation mode is stable-privacy.

Details and research

On our CentOS Linux boxes we use nmcli to rename network adapters. After that we move ifcfg-* files to the new names. This all works as excepted. Before the renaming of the adapter NetworkManagers says the IPv6 address generation mode is EUI-64:

nmcli connection show ens3 | grep addr-gen

ipv6.addr-gen-mode: eui64

But after renaming the adapter (and a reboot) the very same command show different output:

nmcli connection show eth-wan | grep addr-gen

ipv6.addr-gen-mode: stable-privacy

What I've tried

After researching various documentation I've tried different situations to 'restore' the EUI-64 configuration:

  1. Adding IPV6_PRIVACY=no and IPV6_ADDR_GEN_MODE=eui64 to ifcfg-*
  2. Executing nmcli con mod eth-wan ipv6.addr-gen-mode eui64

None of the above result in a visible switch back to EUI-64. But after adding the options on the first situation, the IPv6 configuration effectively is using EUI-64. Even when NetworkManagers states otherwise. I tested this behaviour by watching ip addr output between all changes.

Concluding Questions

  • Will it do any harm that NetworkManager gives other information than provided by the configuration?
  • Is there any way to effectively change the visible NetworkManager configuration, so it is 'in sync' with the working running config?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.