0

I have a running Windows Server 2019 used as a File Server. He is having a problem: When reading/writing files via network share (SMB Protocol) the request takes a long time to complete...

This is happening on Office 97-2003 files, PDFs, Solid Works archives, and some other extensions.

Things i tested:

  1. HARDWARE - HD, NIC, CPU, Memory. All returned good and positive results... No phisical problems
  2. Network: Internal connection and external is OK. Low latency. No loss.
  3. Tried accessing those files LOCALLY only - Problem didnt occur.
  4. Created the SAME structure using ANOTHER server on the same network - Same OS (Win SRV 2019) with even the SAME BUILD! Problem DIDNT happen.

So, basically this problem is just happening on that specific server. I have no idea on what to do

Does anyone went through this and can give me a little help? A light on the end of the tunnel ...

0

I don't have a definitive answer, and the problem appears to be rather unpredictable, but after some research a while back I found this solution and it does appear to work.

On the client computer perform the following - AT YOUR OWN RISK:

In an elevated Powershell prompt run the following command: Enable-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol-Client" -All

Add the registry value ProviderFlags as a REG_DWORD with a value of 1 to HKEY_CURRENT_USER\Network\**Drive Letter** for all mapped drives (where Drive Letter is a registry entry for each mapped drive..

3
  • Wouldn't it be prudent to include a caveat that this is contrary to best practices and significantly reduces the security posture of the client?
    – Semicolon
    Jun 24 '21 at 16:53
  • I suppose. I've always assumed that people evaluate the risks for themselves. I don't take anything I read on the interwebs as gospel.
    – joeqwerty
    Jun 24 '21 at 17:31
  • 1
    With all of the inexperienced people who read and participate in this site, I suspect that most people don't evaluate the risks because they don't even know what they are. Jul 4 '21 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.