0

I have 8x18TB Raid10 mdadm volume on Ubuntu server. When I connect from Windows iSCSI speeds 220MB/sec read 375MB/sec write. I guess it is a iSCSI protocol bottleneck could not improve it. It leaves me multipath.

I have 2 nics on both server and client. I tried many things but could not figure out how to use Multipath or multiple sessions (in windows interface). Tried to connect sessions as

192.168.122.100 --> 192.168.122.110
192.168.123.100 --> 192.168.123.110

I see both portals in portals and create favorite as MPIO but when I use MCS it says it is already connected. Also tried to

192.168.122.100 --> 192.168.122.110
               |--> 192.168.122.111

Could not get it work. What adjustment should I do server side. I am clueless at the moment. By the way windows is windows10 PRO 20H2 so no restrictions on it I guess.

note: We try to make it work fluently with avid media composer. Since it asks for disks. If I cannot get the performance I need from ISCSI, I plan to switch to nbd ? Any good alternatives to iSCSI or other suggestions which works over 10Gbe ethernets and switch ?

Edit: I stumbled upon CNA cards RDMA ISER solution gonna try it ... Suggestions are still welcome.

3
  • Please update the last part of your question, it's not good formatted and asked. Since you get over 200mb/s I believe that the server is already using 10gbit?
    – djdomi
    Jul 4 at 13:07
  • 1
    From what I've found it could be a bug of Windows 10. github.com/MicrosoftDocs/azure-docs/issues/9796 It should work and according to forums it will until your reboot the PC. You will need to enable it again after reboot. Might be helpful as well: social.technet.microsoft.com/Forums/ie/en-US/…
    – Stuka
    Jul 9 at 14:05
  • I have edited the question and I am using X520T2 Intel cards both on server and client. Jul 11 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.