Two weeks ago when I rebooted our Win2008 R2 Server (64-bit) it started to power up and load Windows (Windows 2008 Server) but would then suddenly turn-off and start powering up again (and then just keep suddenly turning off, restart, repeat).

I tried booting into safe mode and last known configuration - no joy. It was falling over on classpnp.sys. So I thought I might have corruption on the disk and tried to repair the server from the CD and then I was able to restore the O/S from a backup. I thought that was the end of it but then the next time the server rebooted I had the same problem. Then trying to repair from CD did not work.

I tried repartitioning the disk and installing Windows 7 instead but the installation did not even complete before the PC was powering off mid-boot. I contacted the hardware supplier and they thought it might be the RAM so they've sent me 3 replacement DIMMs, I've swapped those out and the PC isn't powering off anymore but...

The server was trying to boot from the incomplete Windows 7 install. I took the disk out and deleted the 2 volumes on that disk and now trying to install Win2008 from CD. I get the black screen:

Windows is Loading files ...

that completes, and then the grey screen appears with a cursor, but no window/dialog (I'm expecting it to prompt me what language and keyboard I want to use). The server just sits there. alt+tab, ctrl-alt-del, etc. don't have any effect.

If I try booting with no CD I get

BOOTMGR is missing

How do I get past that grey screen? Or is this a hardware failure?

1 Answer 1


Sounds like you have a hard drive failing or some other kind of hardware. Can you swap drives and test again?

  • Eventually... I just left the server powered on for 15-20 minutes and when I came back found the setup screen was finally there. So I completed the install then checked the disk, didn't find any problems. It seems to be running fine now (it's a dev/test server and not been heavily used yet). When I was trying to install I must have been waiting 1 or 2 minutes at least before I was resorting to the power button thinking something was wrong, although I'm a bit worried there might still be because that didn't seem right. Booting the server now is very quick/responsive though.
    – Dan
    Feb 3, 2010 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.