1

I have a Windows Server 2016 VPS where a web app is hosted.it works fine but when windows install updates,nothing works because,in this case CPU usage is 99% and no user can access the app

I've setup automatic updates in Group Policy this way:

  • in Computer Configuration/Administrative Templates/Windows Components/Windows Update I put Enable for “Configure Automatic Updates”
  • then value 4 for auto download/install and time for every Monday at 3am;not check the automatic maintenance box
  • restart system

but Saturday on 11am no client can work on the web app because of automatic updates(CPU 99%) and I had to disable automatic update and everything went fine

how to fix schedule update to work as set in Group Policy?

thanks

1 Answer 1

0

I found a solution: I put windows update service to manual start,then I installed PSWindowsUpdate

PowerShell Install-Module -Name PSWindowsUpdate

I've created a schedule task for every Thursday at 3am that runs a cmd:

sc config wuauserv start= demand    
PowerShell set-executionpolicy bypass
PowerShell Install-WindowsUpdate -MicrosoftUpdate -AcceptAll -AutoReboot

after the above command the windows update service becomes running, not to cause problems again, I did a second task, run on the same day but later at 5:30 am and which deactivates it:

net stop wuauserv
sc config wuauserv start= disabled 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .