0

I would like to check if jdk 1.6 is supported in AIX 7.2.

We are planning to upgrade from AIX7.1-7.2 (POWER7-POWER9).

But we are not sure if we have to upgrade java . As our development is done in JDK 1.6.

Can anyone suggest if java needs to be upgraded to JDK 1.8 if we are upgrading AIX 7.1-7.2 (POWER 7 TO POWER 9)?

2 Answers 2

1

The Java SDK on AIX page has a section named "Java SE and IBM WebSphere Real Time minimum AIX support levels" that shows the minimum level for JDK 6 as AIX 7200-00 and AIX 7100-00.

Of course, AIX 7100-00 service pack support ended in November of 2013, so you'd want to make sure you're on a currently-supported version (e.g. 7100-05). Also note that AIX 7200-00 service pack support ended in December of 2018, so you'd want to get to 7200-03 or newer.

As an addendum, I'd point out that Oracle has declared that support for version 6 ended December of 2018.

0

You can get the Java JDK directly from IBM. I don't see 1.6, but they do have several versions available.

https://www.ibm.com/support/pages/java-sdk-aix

2
  • We have jdk version available. But wanted to check if jdk 1.6 is supported in power 9 IBM AIX. Is there any dependency issues that may popup like jdk 1.6 and AIX power9(7.2 os)
    – Mahahari
    Sep 2, 2021 at 1:37
  • If you have a valid support contract with IBM for the system you're running the JDK on, I do believe it is "supported". Otherwise community support is your only avenue for help with it. It will run and work if you use the software packaged by IBM and likely not run into any issues that aren't common to Java. Make sure you set your heapsize in the configuration to an amount of system memory you can spare!
    – t3ln3t
    Sep 2, 2021 at 6:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .