0

We have a LDAP server and we use phpldapadmin to manage it. I have not used it since a long time and when I try to login with my admin user, I get the following :

Could not start TLS. (LDAP Server)
Error: Could not start TLS. Please check your LDAP server configuration.

error   Unable to connect to LDAP server LDAP Server
Error: Can't contact LDAP server (-1) for user

error   Failed to Authenticate to server
Invalid Username or Password.

The LDAP server is working fine, I also verified the user's password and it's the right one. I can use that user to ldapsearch on the server on the command line.

The only thing I changed on this server recently was some iptables rules. It used to work perfectly fine so I don't really understand where the problem is. We use a let's encrypt certificate to connect to the ldap server. The server is under Debian 9 and phpldapadmin works with nginx.

EDIT

I've put PLA logs on debug mode and I don't get any more information than before. Nginx doesn't give me any errors in its logs either. I've tried the following command :

ldapsearch -ZZ -H ldap://ldap.mydomain.com -W -D cn=adminuser,dc=mydomain,dc=com -b dc=mydomain,dc=com

and it works fine. Also checking the ssl connection with :

openssl s_client -connect ldap.mydomain.com:636

returns the certificate.

I don't know if PLA can read ldap.conf

1 Answer 1

0

The solution was so simple I couldn't even think about it. I restarted php7.0-fpm and it solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .