I have a RHEL7 VM running on Hyper-V. In my VM, I have a web-based program the I need to access over port 11000. In the VM, the software is configured and is accessible by

I've tried setting up an external v-switch and internal v-switch, both have not been successful as I cannot even ping the virtual switch from within the VM. I am trying to configure this using a NAT Switch.

Here is how I configured the network interface from the host in powershell.

PS> New-NMSwitch -SwitchType Internal -SwitchName "LINK"
PS> New-NetIPAddress -IPAddress "" -PrefixLength 24 -InterfaceAlias "vEthernet (LINK)"
PS> New-NetNAT -InternalIPInterfaceAddressPrefix "" -Name "LINK-NETNAT"
PS> Add-NetNatStaticMapping -ExternalIPAddress "" -ExternalPort 11000 -InternalIPAddress "" -InternalPort 11000 -Protocol TCP -NatName "LINK-NETNAT"

I also allowed the port traffic through Windows firewall:

New-NetFirewallRule -DisplayName "HyperVNAT" -Direction Inbound -LocalPort 11000 -Protocol TCP -Action Allow

All of these commands ran with no issues. I assumed they worked because Network Devices were created with the appropriate parameters provided above.

virbr0 is configured as

I setup eth0 as the following:

eth0 is set to manual addressing as IPv4

DNS and Routes were left as automatic.

Here is a screenshot of ip addr

screenshot - ip addr

When I try to access I get no response.

From the VM, I can only ping and nothing on the outside.

From the Host, I can ping, but no other IP that's inside of the VM. (.122.2 just times out)

My ultimate goal is to be able to access the web interface that is in the VM on port 11000 from the host machine.

  • This appears to be an issue with the virtual machine environment specifically related to IP tables. Adding rules based on this post, has allowed me to ping the VM from the host. I think I need to enable other ports to see if it will work. Sep 9, 2021 at 15:44


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.