1

I installed znapzend on unraid and did the initial configuration. My daemon is running but zfs list -t snapshot shows no datasets available

*** backup plan: citadel ***
         enabled = on
         mbuffer = off
    mbuffer_size = 1G
   post_znap_cmd = off
    pre_znap_cmd = off
       recursive = on
             src = citadel
        src_plan = 7days=>1hour,30days=>4hours,90days=>1day
        tsformat = %Y-%m-%d-%H%M%S
      zend_delay = 0

NOTE: if you have modified your configuration, send a HUP signal
(pkill -HUP znapzend) to your znapzend daemon for it to notice the change.

I created the backup plan like this znapzendzetup create --recursive SRC '7d=>1h,30d=>4h,90d=>1d' citadel

debug shows the below

root@UnRAID:~# znapzend --noaction --debug
=== getDataSetProperties():
        recurse=$VAR1 = 1;

        inherit=$VAR1 = 0;

        DS=$VAR1 = [
          undef
        ];

        lowmemRecurse=0
=== getDataSetProperties(): Is array...
=== getDataSetProperties(): skip array context: value(s) inside undef...
=== getDataSetProperties(): List all local datasets on the system...
# zfs list -H -o name -t filesystem,volume
=== getDataSetProperties(): Looking under 'citadel' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel
=== getDataSetProperties(): FOUND: 'citadel' => 'tsformat' == '%Y-%m-%d-%H%M%S' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'mbuffer' == 'off' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'mbuffer_size' == '1G' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'enabled' == 'on' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'pre_znap_cmd' == 'off' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'zend_delay' == '0' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'post_znap_cmd' == 'off' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'src_plan' == '7days=>1hours,30days=>4hours,90days=>1days' (source: 'local')
=== getDataSetProperties(): FOUND: 'citadel' => 'recursive' == 'on' (source: 'local')
=== getDataSetProperties(): SAVE LAST: 'citadel'
=== getDataSetProperties(): Looking under 'citadel/Documents' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel/Documents
=== getDataSetProperties(): Looking under 'citadel/Media' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel/Media
=== getDataSetProperties(): Looking under 'citadel/TimeMachine' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel/TimeMachine
=== getDataSetProperties(): Looking under 'citadel/Torrent_Downloads' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel/Torrent_Downloads
=== getDataSetProperties(): Looking under 'citadel/software' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel/software
=== getDataSetProperties(): Looking under 'citadel/veeam-backup' with zfsGetType='0', '0' recursion mode and '0' inheritance mode
# zfs get -H -s local -o name,property,value,source all citadel/veeam-backup
=== getDataSetProperties():
        Collected: $VAR1 = {
          'enabled' => 'on',
          'recursive' => 'on',
          'mbuffer' => 'off',
          'src' => 'citadel',
          'post_znap_cmd' => 'off',
          'zend_delay' => '0',
          'tsformat' => '%Y-%m-%d-%H%M%S',
          'src_plan' => '7days=>1hours,30days=>4hours,90days=>1days',
          'mbuffer_size' => '1G',
          'pre_znap_cmd' => 'off'
        };

# zfs list -H -o name -t filesystem,volume citadel
=== getBackupSet() : got 1 dataset(s) with a local backup plan
=== getBackupSet() : got 1 enabled-only dataset(s) with a local backup plan

This is the first time I am using it and I am certain I am doing something wrong. Any help will be appreciated. Thanks

1 Answer 1

1

Spoke too soon guys. It is working. I had to wait till the new hour started

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.