0

One of the server machines we use for database backup procedures is having issues and I ran out of ideas. At some point, it froze completely, and so it was forcefully rebooted. After that, the machine couldn't boot into the OS anymore.

The machine was running Ubuntu 18.04.3 LTS on an HPE Proliant ML30 Gen9, and upon closer inspection, I realized the ubuntu boot option was gone.

HPE Proliant was configured with Smart Array, Secure Boot disabled, and UEFI.

After some research, I tried tinkering with the UEFI Shell but to no avail, since the OS isn't listed as a File System, but the storage devices are being shown.

UEFI SHELL map command

Then I tried running the HPE Embedded Smart Storage Administrator, and I saw for a brief moment the GRUB 2 interface while HPE SSA was loading. After HPE SSA was finished loading, I pressed c and was able to enter GRUB's cli.

GRUB cli in HPE environment

Here I was able to navigate the hard drives and eventually found all the data was OK, there was no data loss, but somehow the bootloader was lost to the UEFI environment.

Ubuntu's Hard Drive

The /boot/efi directory is empty, but the /boot/grub directory has some files and folders.

Then I tried booting Ubuntu, but this was the result:

Ubuntu booting up

At this point, I ran out of ideas and I couldn't keep searching for an answer because questions became too specific.

I even went back to the UEFI Shell trying to enter the BLK3 device (because it looks like it is that partition) but I couldn't navigate to the /boot folder so I could use the bfcg command.

I don't know what else I can do to restore Ubuntu's bootloader. Any advice or help will be appreciated.

PS: The server used to have a graphical interface. The team uses TeamViewer to monitor the server and check on the backup procedures.

PS2: insmod all_video didn't work. grub prompted a " file not found" error, even after setting the root variable.

PS3: I tried plugging some USB flash drives. I tried Ubuntu 18.04.3 partitioned as GPT, Ubuntu 20.04.3 partitioned as GPT, and Ubuntu 20.04.3 partitioned as MBR. None were picked up by HPE Proliant (Legacy AND UEFI), nor do they appear in UEFI Shell, nor do I know how to mount them from the GRUB interface.

PS4: As a last resort, I could install RHEL using the HPE Embedded Intelligent Provisioning tool.

PS5: This is my first time using HPE Proliant systems.

Edit: (hd2), (hd3), (hd4) and their related partitions were created when I used HPE tools. On reboot, those partitions and their associated file systems would be gone from the UEFI Shell and the Boot options.

4
  • /boot/efi is normally an empty directory - its merely the mount point where the EFI system partition gets mounted to. Its not the actual location of binaries for EFI - those would generally be stored on a different partition, in a (more or less) FAT file system.
    – anx
    Sep 11, 2021 at 18:08
  • 1
  • @anx if that's the mount point, where would the EFI system partition be? (hd0,gpt1) is the actual partition for the backup data, where (hd0,gpt5) is the actual OS. iirc the only partition that had a FAT file system was (hd1). How can I restore mount points if the OS is not being booted up? Sep 11, 2021 at 21:45
  • @MichaelHampton thanks for the link, I'll test that on Monday. Only question I have is... boot-repair boots just like any other OS? I'm currently having issues booting any live-USB OS installer, that might pose a problem Sep 11, 2021 at 21:45

1 Answer 1

0

Found a way to fix the issue.

As suspected, the /boot partition was gone, because all the partitions were rearranged and some of them were lost. After updating the HPE Proliant firmware, I was able to boot from external USB drives. At that point I used an Ubuntu live USB to take care of the partitions and rearrange them, making sure to set the /boot partition as the first partition and sector of the drive.

Once that was done, I could boot into the GRUB shell and avoid the No bootable devices were detected. Please attach a UEFI bootable device.... Ubuntu was still missing from the list, so I had to do a completely clean install. I erased all the partitions before installing and I was finally able to boot into Ubuntu after the installation was finished.

I tried using Boot-Repair, but to no avail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.