0

I am trying to understand the root cause of my high network egress..

GCP network monitoring shows approx 600 KB/s and bills accordingly If I do iftop on my VM, the sent (Tx) traffic sort of correlates with this number.. But if I run nethogs to understand the process which is initiating this traffic, I only get 20%-40% of the number reported by iftop..

Where is the discrepancy in nethogs vs iftop..

0

Just to continue your previous Stackoverflow question. I updated the answer. Please see below.

Verify on your end if the traffic is TCP or UDP. There's still issue on nethogs when it comes to getting UDP bandwidth.

Refer on links below regarding issues on nethogs.

GIT HUB
Nethogs significantly underestimating Zoom traffic
Reported bandwidth seems too low/inaccurate

STACK EXCHANGE
Why doesn't nethogs show correct total

I tried to install the latest version from raboof (8.5-87) on my end using this guide (Full discussion here) to capture both TCP/UDP traffic by running sudo nethogs -C. Still the same bandwitdh with 8.2 version. Seems to be that nethogs has limitations on displaying bandwidth.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.