0

I am trying to use podman-compose to spin up an environment. The env is air gapped from the internet and uses a local docker registry to pull images.

The issue is when I run podman-compose up, it tries to create the initial infra container from the default image "k8s.gcr.io/pause" which is located on the internet.

I have pushed this image to our local registry, but I can't find how to tell podman to use this image instead of the internet one.

1
  • I was able to get around this by creating the infr container manually "podman pod create --name=<name of infra used by containers> --share net --infra --infra-image company-registry.com/k8s.gcr.io/pause:3.5", but hoping there is a default value somewhere as this still throws an ignorable error.
    – dranobob
    Oct 14 at 2:45
1

change line "infra_image" in file containers.conf

Container engines will read containers.conf files in up to three locations in the following order:

  1. /usr/share/containers/containers.conf
  2. /etc/containers/containers.conf
  3. $HOME/.config/containers/containers.conf (Rootless containers ONLY)
New contributor
Lars Grotell is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.