4

When I try to run the hello-world docker image I get the following error:

ubuntu@ubuntu:~$ sudo docker run hello-world
docker: Error response from daemon: failed to create endpoint frosty_varahamihira on network bridge: failed to add the host (vethc6c068f) <=> sandbox (veth82a7475) pair interfaces: operation not supported.
ERRO[0000] error waiting for container: context canceled

I red this post which seems to be the exact same problem but I can't manage to install a different kernel.

I tried the following to install a new kernel, which led me to the next error:

ubuntu@ubuntu:~$ sudo wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.7.5/amd64/linux-headers-5.7.5-050705-generic_5.7.5-050705.202006220832_amd64.deb
--2021-10-22 13:47:14--  https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.7.5/amd64/linux-headers-5.7.5-050705-generic_5.7.5-050705.202006220832_amd64.deb
Resolving kernel.ubuntu.com (kernel.ubuntu.com)... 91.189.94.216
Connecting to kernel.ubuntu.com (kernel.ubuntu.com)|91.189.94.216|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1223448 (1.2M) [application/x-debian-package]
Saving to: ‘linux-headers-5.7.5-050705-generic_5.7.5-050705.202006220832_amd64.deb’

linux-headers-5.7.5-050705-generic_5.7.5-05070 100%[===================================================================================================>]   1.17M  2.53MB/s    in 0.5s

2021-10-22 13:47:20 (2.53 MB/s) - ‘linux-headers-5.7.5-050705-generic_5.7.5-050705.202006220832_amd64.deb’ saved [1223448/1223448]

ubuntu@ubuntu:~$ sudo dpkg -i *.deb
dpkg: error processing archive linux-headers-5.7.5-050705-generic_5.7.5-050705.202006220832_amd64.deb (--install):
 package architecture (amd64) does not match system (arm64)
dpkg: error processing archive linux-image-unsigned-5.14.9-051409-generic_5.14.9-051409.202109300934_amd64.deb (--install):
 package architecture (amd64) does not match system (arm64)
Errors were encountered while processing:
 linux-headers-5.7.5-050705-generic_5.7.5-050705.202006220832_amd64.deb
 linux-image-unsigned-5.14.9-051409-generic_5.14.9-051409.202109300934_amd64.deb

For that error I found this for example, which did not help.

This might also help

ubuntu@ubuntu:~$ ls -l /boot
total 33299
-rw------- 1 root root  5112454 Sep 29 07:51 System.map-5.13.0-1008-raspi
-rw-r--r-- 1 root root   241335 Sep 29 07:51 config-5.13.0-1008-raspi
drwxr-xr-x 4 root root     2560 Jan  1  1970 firmware
lrwxrwxrwx 1 root root       28 Oct 13 13:29 initrd.img -> initrd.img-5.13.0-1008-raspi
-rw-r--r-- 1 root root 19242515 Oct 13 13:30 initrd.img-5.13.0-1008-raspi
lrwxrwxrwx 1 root root       28 Oct 13 13:29 initrd.img.old -> initrd.img-5.13.0-1008-raspi
lrwxrwxrwx 1 root root       25 Oct 13 13:29 vmlinuz -> vmlinuz-5.13.0-1008-raspi
-rw------- 1 root root  9492544 Sep 29 07:51 vmlinuz-5.13.0-1008-raspi
lrwxrwxrwx 1 root root       25 Oct 13 13:29 vmlinuz.old -> vmlinuz-5.13.0-1008-raspi

I am using Raspberry Pi 4 Model B Rev 1.2. Here other versions:

Docker

ubuntu@ubuntu:~$ docker --version
Docker version 20.10.7, build 20.10.7-0ubuntu5

Ubuntu OS-Version

Ubuntu 21.10 aarch64

Kernel

ubuntu@ubuntu:~$ uname -rn
ubuntu 5.13.0-1008-raspi

I am thankful for any hint and idea!

6
  • 1
    sorry bro, but you're trying to install an amd64 kernel on an arm64 system. Did your read the error messages ? [ package architecture (amd64) does not match system (arm64) ]. Also your current kernel is more recent than the one you are trying to install. Is it really what you want to do ? Oct 22 '21 at 15:17
  • 1
    please post output of command grep VETH /boot/config-5.13.0-1008-raspi and lsmod|grep veth Oct 22 '21 at 15:19
  • 1
    the virtual ethernet module may not be loaded, that's what I'd like to see. => sudo lsmod | grep veth to see if the module is loaded and sudo modprobe veth to load it Oct 22 '21 at 15:33
  • 1
    Thank you for your answer! No that's not what I want and you're, my kernel is quite up to date. What I want is to solve the error I get when I run a Docker-Container. The output for ` grep VETH /boot/config-5.13.0-1008-raspi` is CONFIG_VETH=m. For lsmod|grep veth I do not get an ouput. Could you explain to me what I can conclude from that?
    – Justus_505
    Oct 22 '21 at 15:34
  • 1
    Here the output for sudo modprobe veth: modprobe: FATAL: Module veth not found in directory /lib/modules/5.13.0-1008-raspi For sudo lsmod | grep veth I do not get an output.
    – Justus_505
    Oct 22 '21 at 15:37
8

install the linux-modules-extra-raspi package to get the veth module.

1
  • 1
    This solved this issue for me, thanks!
    – segfault
    Oct 24 '21 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.