1

We are planning to upgrade our Cassandra servers from 3.0.11 to 4.0.1 Here it says to use JDK 8. I would like to know if as of this writing this is still the case. I believe the latest released Oracle version is JDK 17.

1

The primary version for Cassandra 4.0 is Java 8. The Java 11 is marked as experimental, but there was a recent discussion of removing that label for 4.0.

But work on the Java 17 has started only recently, and it may not be supported for 4.0, but for newer major releases

3
  • Okay. So for a production environment you would recommend we use Java 8?
    – adinas
    Nov 23 '21 at 12:03
  • 1
    Most probably. Although look into mailing list, there were some people saying that they are using Java 11 in prod
    – Alex Ott
    Nov 23 '21 at 12:20
  • Yes, seems like many support making 11 "non experimental"
    – adinas
    Nov 23 '21 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.