I installed apache then I am able to access the default page from the command line:

$ wget

Using webmin in web browser:


Servers>Apache WebServer>Global configuration>Configure Apache Modules>

Enable the dav modules:

Configure Apache Modules
Module    Current state
dav       Enable
dav_fs    Enable
dav_lock  Enable
<Enable Selected Modules>

Restarted apache at command line:

$ sudo /etc/init.d/apache2 restart

Invoke command line dav client:

$ cadaver
Could not access / (not WebDAV-enabled?):
405 Method Not Allowed
Connection to `' closed.

What is missing?

  • How come you're not using mod_dav? – blueberryfields Feb 19 '10 at 19:07
  • I assume that "dav" in "Configure Apache Modules" means mod_dav. – CW Holeman II Feb 19 '10 at 21:53

What does Apache's error log say? I find the error log to be very useful in troubleshooting WebDAV errors.

Did you enable WebDAV for any URLs? Example:

<Location />
   Dav On

Did you set up a DavLockDB?

  • +1 Dav has to be enabled for specific locations – Chris S Jan 12 '12 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.