0

Situation: FreeBSD 13 server with Apache 2.4 as reverse proxy on SSL. Bastille jail with nginx on port 80 and joomla 4.04

Problem: When doing a POST within Joomla (actually any POST except the one from logging in), the update gets handled okay but it then redirects back to the original full URL without a trailing slash. This cannot, of course, be resolved at the DNS level and results in a 404.

I tried replacing nginx with apache 2.4 but the problem stays.

In the Joomla configuration.php file I tried several options for the $live_url value (including a trailing backslash) but that didn't do the trick either. (tbh I didn't see any difference if it had a value or not).

As I'm new to Joomla, I didn't found any way of debugging to see where exactly this goes wrong and how to fix it.

1 Answer 1

0

As it turned out, the problem was caused by the front-facing Apache reverse proxy server, where in the http redirect to https the trailing '/' was missing. And because joomla gives a 303 (see other) to the non-SSL version of the URL (HTTP) it was redirected by the Apache server to a non-valid URL.

Now I have to figure out why Joomla redirects to a HTTP URL and doesn't stay with relative addressing as it is behind a reverse proxy who's handling the SSL part.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.