5

on our terminal server all users have minimal (i.e. default) permissions. None are local administrators on that machine.

Still Java Runtime displays message to every user that an update is available. Clicking on the update asks for admin-credentials, which none of the users have.

How can I stop Java from showing the update notice to all the users? Only administrators should see it. Its pretty annoying that lots of users contact us whenever Java requires an update.

1

2 Answers 2

2

You can try disabling the java update via regedit: http://www.blackmanticore.com/4642715f947c54ea58ecfbef9160c1b3

What we do at work is create MSI installations (or download them), and modify it's MSI install parameters so it doesn't check for updates automatically. I'll post the actual parameters tomorrow. You could do this and re-install so the new parameters can be applied.

1
  • URL is dead. Any updated location available? Aug 8, 2016 at 16:10
5

you can also block the "jusched.exe" from running, via GPO. so the java update schedule will not run, and you can install updates manually, via exe or msi

1
  • I also used GPO to do this as I found the registry settings were not being honored, depending on java version. GPO > Users Config > Policies > Admin Templates > System > Don't run specified Windows applications
    – prl77
    Jun 24, 2014 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.