I have a situation where Host A (USB smart card reader connected) trying to RDP'ed to Host B, however, Host B was not able to detect the smart card reader on Host A in the remote session.

Thing I have tried:

  1. Directly connect the USB smart card reader on Host B. Host B able to detect the reader. I have also confirmed that the smart card able to detect on host A when connected directly.

  2. When specifying IP in mstsc.exe, smart card option was checked under Local devices and resources on Host A. But Host B still unable to detect the reader on Host A.

  3. In Host A and B group policy, I have confirmed that every policy in Computer Configuration >Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection were "Not Configured".

  4. I got another machine, Host C. So I tried from Host A RDP'ed onto Host C, the smart card on Host A can be detected on Host C.

Host B Specification

Edition: Windows 10 Enterprise LTSC

Version: 1809

Build: 17763.2183

What I wanted to achieve is Host B able to detect the smart card reader connected to Host A during the remote session from Host A to Host B.

I have spent quite sometime for this issue but still not able to find out what is the issue. Anyone can shed some lights regarding this ?

Thanks in advance

1 Answer 1


If you haven't solved the problem yet, maybe I can help you!

I recently read an article, in this situation you need to look at the Windows logs on Host Y after the RDP connection has been established. There should be error messages or warnings that point you toward the problem so it can be addressed. See also the article emv smart card reader for other possibilities of problems and solutions.

Hope I was able to help you!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .