1

We are replacing a Juniper EX4200 stack with a new EX3400 stack. During the migration, we setup a bridge link between the two so that things that hadn't migrated yet could talk to things that had. This worked well until we got down to the last connection, shown in the attached image. When the red connection is in place, connectivity between client-router-1 and client-router-2 works fine. When the connection to ether6 on client-router-1 is replaced with the green connection, it stops working. A key symptom is that pings from intermediate-switch to 10.0.0.1 go out interface ge-0/1/3 instead of ge-0/0/4 (determined by mirroring ge-1/2/3 on new-router and tsharking).

Arp on intermediate-switch shows the right info, but just "vlan.1210", not which physical interface the mac appears on:

> show arp 
MAC Address       Address         Name                      Interface               Flags
ec:9b:8b:21:b2:ae 10.0.0.1        10.0.0.1                  vlan.1210               none
e4:8d:8c:1b:ae:09 10.0.0.10       10.0.0.10                 vlan.1210               none

spanning tree is disabled on intermediate-switch and on new-router ge-1/2/3, which otherwise would be the first thing that comes to mind when remote changes have local effect (we've run into that nastiness before).

Network Diagram

1 Answer 1

0

The problem ended up being solved by changing the link between intermediate-router and client-router-2 to an access (untagged) port (fortunately, the other vlans were no longer in use so this was a viable option). I don't know why that fixed it, but it did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.