Whilst I'm developing with RedHat Cluster, I'd like to be able to disable fencing completely. The documentation for this stuff is fairly lacking - can I do this at all, or should I be looking to fake up a null fencing method of some sort?


you can use manual fencing for testing. search for fence_manual in this doc

this will not disable fencing, but nothing will happen when you not want to.

  • I looked at fence_manual, but it looked as though this was more interactive than I was after. – Jon Topper Feb 5 '10 at 20:26


If you disable it when you're developing it, you'll regret it when you turn it on and it doesn't behave the way you want it to. Getting fencing to work right is one of, if not the, hardest parts of setting up RHCS. At least it was for me.

I'd recommend biting the bullet and getting that working first before you add any services.

* - because of this: http://www.standalone-sysadmin.com/blog/2009/04/howto-redhat-cluster-suite/


you can backup /sbin/fence* and replace the files with empty scripts, that maybe will just log a received command, but will not do any actual fencing


Thank you dyasny, I used your answer to solve my similar issue. This is how I did it.

[saurap@node1 sbin]# find . -name "fence*" -exec mv {} /fencebackup \;

switch to /fencebackup

[saurap@node1 fencebackup]# ls >sbinnames

then write a script to put the same named empty script on /sbin

for i in `cat sbinnames`
    cd /sbin
    touch $i
    echo "#!/bin/bash" > $i
    chmod 755 $i

Now you have backup of all your fence* scripts under /fencebackup and empty fence* scripts under /sbin.


You just put:


into /etc/sysconfig/cman

  • after enable it my rgmanager doesn't starting... – Satish Feb 10 '13 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.