1

I initially had roaming profiles implemented but it turned into a massive headache of constant issues and sync failures. Decided to remove roaming profiles and remove the roaming location from each user in AD, then setup a GP to force local profiles on the hosts. This works for new users and existing users show as "local/local" when looking at user profiles in System & Security --> System --> Advanced --> User Profiles. .

When I login and type "set" into a CMD window though, it shows APPDATA as still pointing to the NFS/SMB roaming location (even though the user profile reports as a local profile).

I have verified nothing is setup in AD (User properties --> Profile --> Profile Path) is empty.

I created a GPO at the top level where I set “Only allow local user profiles” and “Prevent Roaming Profile Changes from propagating to the server” to enabled.

Users are able to login and navigate to Control Panel --> System & Security --> System --> Advanced Settings --> User Profiles. The account I login with shows Type and status of "local".

I ran gpresult /H and searched through the policies for anything "Roaming" and the only things that showed up were "Only allow local user profiles” and “Prevent Roaming Profile Changes from propagating to the server” which I implemented above to disable these roaming profiles.

Creating a new user and logging in doesn't automatically setup the user with a roaming profile (ie APPDATA point to C:\Users\etc).

How do I get the profiles to point APPDATA back to local or what could be stopping the profiles from returning back to normal?

3
  • What exactly do you mean by "the NFS roaming location"? Feb 3 at 18:30
  • 1
    I had an NFS server where I setup the roaming profiles to. In AD Users and computers, I would select an account and then the Profile tab. I then specified the Profile Path as \\<nfs_server>\HOME\%username%
    – IT_User
    Feb 3 at 18:45
  • Apologies, I meant a NFS/SMB share.
    – IT_User
    Feb 3 at 19:39

2 Answers 2

1

Only solution I was able to find was to delete the accounts and create new ones. This required removing the accounts, deleting the C:\Users\Username folder on the windows computer the users uses, fixing permissions on the old shared folder, then having the user login. Not ideal but it works.

1

Late to the party, but APPDATA can be redirected with the redirected folder settings. (romaing profile at on or off)

If someone erased that GPO and not desactivated the settings, it might be the cause of your headache, as in such case you need to make a new GPO and force the settings to be disabled, so it desactave the last time it was at On.

1
  • 1
    Appreciate it! Will look into that and see if it may have been the underlying issue.
    – IT_User
    Mar 29 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.