0

I want to use the following configuration for Postfix:

smtpd_relay_restrictions = permit_mynetworks reject_sender_login_mismatch permit_sasl_authenticated defer_unauth_destination, check_policy_service unix:private/policyd-spf
smtpd_sender_login_maps = hash:/etc/postfix/controlled_envelope_senders

controlled_envelope_senders contains a single entry for my SASL user:

xyz@example.com username@example.com

This setup mostly works fine, but there are two issues.

  1. Postfix accepts message from other addresses (e.g. abc@example.com or def@otherdomain.org) for user@example.com:
Feb  6 08:28:21 eden postfix/submission/smtpd[568746]: connect from cable-87-79-207-4.nc.de[87.79.207.4]
Feb  6 08:28:21 eden postfix/submission/smtpd[568746]: F0F207F941: client=cable-87-79-207-4.nc.de[87.79.207.4], sasl_method=PLAIN, sasl_username=user@example.com
Feb  6 08:28:22 eden postfix/cleanup[568753]: F0F207F941: message-id=<Yf+GpT7tRUKyS6b5@example.com>
Feb  6 08:28:22 eden postfix/qmgr[568743]: F0F207F941: from=<abc@example.com>, size=770, nrcpt=2 (queue active)
  1. For external messages sent to one of my virtual_alias_domains, there is a warning in mail.log:
Feb  6 08:45:35 eden postfix/smtpd[568806]: warning: restriction `reject_authenticated_sender_login_mismatch' ignored: no SASL support

I did not specify reject_authenticated_sender_login_mismatch, and these messages are not sent by authenticated senders – so what does this warning refer to?

Thanks, Jan

1 Answer 1

0

Problem solved: The parameters for submission in /etc/postfix/master.cf did not specify reject_sender_login_mismatch (overwriting the setting in main.cf), and since sasl was not for smtpd in main.cf, so the reject directive made no sense there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.