Devices file sys_wwid nvme. PVID last seen on /dev/nvme0n1p2 not found.


Please remove the lvm.conf filter, it is ignored with the devices file.

Seems this is happening on RHEL 9 / CentOS 9.

  • Sorry, is this a question? Or an answer? Or are you documenting both for future googlers? If so, please rephrase your question into a proper question and then post your answer as an answer to it.
    – shearn89
    Feb 14, 2022 at 11:55

2 Answers 2


While awaiting a fix this can be bypassed by setting use_devicesfile=0 inside of /etc/lvm/lvm.conf

For more information on this issue you can see the BugZilla report here: https://bugzilla.redhat.com/show_bug.cgi?id=1965941

  • Perfect solution!!
    – Vijay S B
    Nov 4, 2022 at 12:10
  • Thanks Steven, this really saved me. Jun 19 at 22:21

This is probably caused by some outdated device entries in the devices file located in /etc/lvm/devices/system.devices

You can remove those entries with the lvmdevices command.

sudo lvmdevices --deldev /dev/nvme0n1p2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .