7
Devices file sys_wwid nvme. PVID last seen on /dev/nvme0n1p2 not found.

OR

Please remove the lvm.conf filter, it is ignored with the devices file.

Seems this is happening on RHEL 9 / CentOS 9.

1
  • Sorry, is this a question? Or an answer? Or are you documenting both for future googlers? If so, please rephrase your question into a proper question and then post your answer as an answer to it.
    – shearn89
    Commented Feb 14, 2022 at 11:55

3 Answers 3

9

While awaiting a fix this can be bypassed by setting use_devicesfile=0 inside of /etc/lvm/lvm.conf

For more information on this issue you can see the BugZilla report here: https://bugzilla.redhat.com/show_bug.cgi?id=1965941

2
  • Perfect solution!!
    – Vijay S B
    Commented Nov 4, 2022 at 12:10
  • Thanks Steven, this really saved me. Commented Jun 19, 2023 at 22:21
5

This is probably caused by some outdated device entries in the devices file located in /etc/lvm/devices/system.devices

You can remove those entries with the lvmdevices command.

sudo lvmdevices --deldev /dev/nvme0n1p2
1
  • Thanks it worked for me. In mine case I executed this order of steps: created partition /dev/nvme1n1p1 (type 8E Linux LVM). pvcreate /dev/nvme1n1p1, vgcreate vg01 /dev/nvme1n1p1, vgremove vg01, removed partition /dev/nvme1n1p1. So mine problem was deletion of partition without executing pvremove 1st.
    – ibre5041
    Commented Jan 16 at 13:38
0

you may find that deleting the relevant wwn entry in /etc/multipath/wwwid is required (seems to persist across reboots ?) which is what finally worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .