4

For some time we have been using jumbo frames on several computers without problems.

But suddenly I am no longer able to increase the MTU on some computers to more than 1500 Bytes.

netsh returns error for any MTU value higher than 1500:

netsh interface ipv4 set subinterface “Local Area Connection 3” mtu=4096 store=persistent

The parameter is incorrect.

Jumbo frames are enabled in the Ethernet driver. The problem is on several computers with many different ethernet interfaces. But it still works on some computers.

On one computer the MTU was set to 4096 and it was working fine for a year or so. Last week I lowered it to 1500, and after that I could not set it back to 4096 again.

All computers run Windows 10 Pro.

Could this problem be related to any recent windows update? Is there anything else which can constrain the MTU setting in windows?

EDIT1

Tested on Ethernet adapters: Intel I219-LM, D-Link USB, QNAP QNA-T310G1T and ASIX AX88179. Same result on all. And at least the Intel and QNAP are known to have worked before on these computers.

Interestingly, it does work on the WMware virtual NICs on the same computer.

EDIT2

The same problem recently reported by another user on elevenforum. No solution other than reinstalling windows: https://www.elevenforum.com/t/setting-jumbo-packets-does-not-change-the-mtu.3505/

9
  • 1
    Interesting. On my Windows 11 machine (fully patched), I can set MTU=4096 on an interface, but not on a subinterface.
    – mfinni
    Commented Feb 16, 2022 at 20:18
  • Did you use this command: "netsh interface ipv4 set interface "12" mtu=4096 store=persistent"? When I do that I get an "OK" back, but it does not actually change the MTU. Could you check with "netsh interface ipv4 show interfaces" if you were able to actually change the MTU? Commented Feb 16, 2022 at 20:49
  • Yes, that's what I did, and I didn't check that it actually made the change. I did find that going into the UI for the config on my NIC driver and setting "Jumbo Packets" from "disabled" to "9014" did set the MTU on my interface and subinterface to 8192 - so this might be more a NIC driver issue than a Windows one
    – mfinni
    Commented Feb 16, 2022 at 21:00
  • When I change the NIC driver config to 4088 or 9014, nothing changes in netsh. I have had to explicitly set it on the subinterface in netsh as well. Except that does not work anymore. On multiple computers with different NICs. Commented Feb 16, 2022 at 21:49
  • 1
    Still, I think you might be onto something. I'll have to map out exactly which combinations of NICs and computers has the problem. To see if there is a pattern. Commented Feb 16, 2022 at 23:33

1 Answer 1

1

By PowerShell on Windows for Ethernet (Check Valid Values):

Get-NetAdapterAdvancedProperty | Where DisplayName -Like "Jumbo*" `
| Select DisplayName,DisplayValue,RegistryValue,ValidDisplayValues,ValidRegistryValues
DisplayName         : Jumbo Packet
DisplayValue        : Disabled
RegistryValue       : {1514}
ValidDisplayValues  : {Disabled, 4088 Bytes, 9014 Bytes}
ValidRegistryValues : {1514, 4088, 9014}

DisplayName         : Jumbo Packet
DisplayValue        : 1514
RegistryValue       : {1514}
ValidDisplayValues  : {1514, 4088, 9014}
ValidRegistryValues : {1514, 4088, 9014}

Values can be configure using:

Set-NetAdapterAdvancedProperty -DisplayName ...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .