SCVMM is failing to add a Host with an error saying:

VMM is unable to complete the request. The connection to the agent hostservername.domain.local (name changed to protect innocent) was lost. (Unknown errror (0x80338126))

Host machine: Server 2008R2 Std - Only role is Hyper-V

SCVMM Machine: Server 2008R2 Std - Roles include: IIS, WSUS, File Server.

Domain: Windows Server 2003 functional level. Domain controller is a Small Business Server 2003 SP2 DC.

WinRM is configured on both servers and winrm id -r:servername commands successfuly return details between both machines. Server's can be remotely administered by use of Server Manager from a third machine. Operating System: Windows Server 2008

Debugview Trace output has the following line of interest:

[2772] 0AD4.0FCC::02/04-01:29:13.470#09:ClusterHelper.cs(570): Error getting cluster details for hostservername.domain.local (name changed to protect innocent)

[2772] 0AD4.0FCC::02/04-01:29:13.471#09:ClusterHelper.cs(570): System.Management.ManagementException: Invalid namespace

Any help gladly appreciated :-) I've reinstalled SCVMM w/ factory defaults, reenabled WinRM on both boxes, and disabled Windows Firewalls, everything I can think of.

  • is dns clean ? nslookup (fqdn & hostname) report only good ip ? Is the Hyper-V server member of your AD ? Did you install the scvvm agent manually on the hyper-v server ? – Mathieu Chateau Feb 4 '10 at 8:21
  • DNS is indeed clean (flushcache and nslookup report the right IP). Yes, the host is a member of the same domain. No I did not install the agent manually, should I? – Sangheili Feb 4 '10 at 17:41

Solution: The agent somehow got installed but not correctly onto the host during the process. Removing this agent and manually installing it onto the host allowed SCVMM to add the host with no problems.

| improve this answer | |

Try the following blog site. I had some issues with SCVMM as well and MS virtualization support pointed me to this site to rule out some common issues.


Hopefully this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.