1

I have installed IIS 6.0 Manager and SMTP Server. When I right-click on [SMTP Virtual Server #1] and then click on Properties, I am getting this error "MMC has detected an error in a snap-in. It is recommended that you shut down and restart MMC."

I have tried this method: fix-mmc-has-detected-an-error-in-a-snap-in-when-a-non-administrator-starts-sna-manager-in-host-integration-server

I entered HIS Administrators in the object names but got a message that says HIS Administrators not found in the object names. But I added server administrator there. In the article, "Restart the SnaBase service on the server that is running Host Integration Server." I could not find the SnaBase service. Do I need to restart IIS Server?

1

2 Answers 2

8

We found that doing the following worked, and can now edit the settings in the II6 Manager without errors (and without crashing when applying settings) every time:

  1. Stop SMTPSVC service [Display Name: Simple Mail Transfer Protocol (SMTP)]
  2. Stop IISADMIN service [Display name: IIS Admin Service]
  3. Edit "C:\Windows\System32\inetsrv\MetaBase.xml"
  4. Find: <IIsSmtpServer Location ="/LM/SmtpSvc/1"
  5. Add (Settings are alphabetical): RelayIpList=""
  6. Save file
  7. Start IISAdmin Service
  8. Start SMTPSVC service

You can now open the Internet Information Services (IIS) 6.0 Manager (InetMgr6.exe) and work like normal. The setting above relates to the Access Tab > Relay Restrictions section, but doesn't set anything in it (i.e. "all except the below list" with a blank list).

After setting this value you can change it to what you need it to be. (i.e. the value doesn't need to be 'null' for the fix to work, just so long as the variable is present in the file).

The above has been tested on a few new installs of Windows Server 2022, and has worked for us every time. If you have done an upgrade there are some other things to consider (seems like the SMTP service is not installed after upgrade so will require a backup of the settings that can be applied post reinstalling the service. But that is discussed in other topics).

PS: Remember to set the SMTPSVC service to start "automatically". By default its set to "manual".

Source: Server 2022 SMTP Server issue

0

The SMPT service is officially end of life, so don't waste any more time on it and migrate to an alternative please,

https://stackoverflow.com/a/71984463/11182

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .