2

Whenever I try to start apache server on my local development computer I get prompted an error message as follows:

The requested operation has failed

httpd.conf was not tampered with. How do I set it up to work?

  • 2
    Do you see anything helpful in /var/log/httpd/error_log? – Christopher Karel Feb 4 '10 at 16:10
  • I don't have that directory (var) inside my Apache installation. – Ron Feb 4 '10 at 16:11
  • I lold at this ^ – Jorge Fuentes González Jun 30 '13 at 19:49
6

This is usually caused by one of two problems:

  1. You already have something running on Port 80. It's most common that your development box has IIS installed on it, and IIS is using port 80. You can solve this issue by any of:

    • stopping the IIS service ("World Wide Web Publishing Service")
    • changing the binding on the IIS site
    • uninstall IIS (or remove the Feature in Vista/2008 or newer OSes)
  2. The Apache service is disabled. Open services.msc and check the Apache service, make sure it's not disabled. It should be set to Manual or Automatic start-up, depending on your environment.

| improve this answer | |
  • For example Skype reserves (for wtf reason) port 80. If you are running Skype on your machine, try to turn it off, start Apache and then turn Skype back on. – Dejv Aug 3 '16 at 14:01
1

Check the path in services.msc relating to Apache (default is Apache2.2 I think) to see if it matches path to your httpd.exe.

That fixed it for me.

| improve this answer | |
  • Where did you see that invisible tag about Windows? :) – 0xC0000022L Mar 6 '12 at 22:59
  • 1
    That's a Windows service error. This is likely an WAMP stack or similar. – Chris S Jun 5 '13 at 13:22
1

if apache is not starting and getting error "Requested operation failed"

go to the command prompt : services.msc search for Apache> right click and select properties. In the General tab one startup type drop down is there. Change it to Automatic and click Apply. Then Start button will get enabled.

| improve this answer | |