My question is this:

Can anyone suggest a linux server that runs mysql really well with really low overhead (other than Ubuntu)?

And here's why I have this question:

I have a PE1950 III that has given me no end of trouble. This isn't my first PE1950 but it is my newest. I've attempted to install at least 6 different versions of Ubuntu on this server (including 9.10) but I always get the error after the installation completes and I reboot the system.

usb... device not accepting address2... BusyBox

I've tried troubleshooting the issue with limited success. Oddly, I can run any distro of Ubuntu on this box as long as I have ESXI 4 installed first.

But the error message and troubleshooting it are really beside the point now since I'm thinking I'd like to try another distro like Damn Small Linux or something like that.

The only other item that I'll be running on the box is sendmail. I'll probably config iptables as well.

  • They have stopped shipping us the PE1950, it is obsolete. This machine is fairly old?
    – MarkR
    Commented Feb 11, 2010 at 6:04
  • Obsolete - are you kidding? What matters that I purchased PE1950 III 8 months ago? I have PE1950 machines first gen that I purchased 3 years ago that work fine. Besides, errors like this usually arise because a machine was built after the OS was released. The older the machine, the higher your chances that someone will have written drivers with it in mind.
    – Patrick R
    Commented Feb 11, 2010 at 12:58

4 Answers 4


"Really low overhead" is a non-requirement for a database server. As you will be using lots and lots of ram, you don't really care if the OS uses a few megs more (particularly as the page tables for reasonable sized memory typically take up loads more than your kernel on x86 architecture)

Use Centos, you know it will work. Ubuntu or Gentoo other hippy weirdness is great for the odd desktop, but I wouldn't let it near a server.

If you think you need "low overhead" then turn off a few things you don't need. You'll save a few 100kb of RAM, and feel happy (when the page tables take up 1G)

Just whatever you do, don't use a 32-bit OS. Databases do not work on 32-bit OS*, use 64.

* actually they do "work" but cannot use the ram properly on modern hardware, you may as well run it on an old 486 if you have a 32-bit OS.

  • +1 for brief desc of 32 vs 64 for databases. hope you're exaggerating a bit about 486 but I'm going to definitely move into the 64-bit environment to convince myself.
    – Patrick R
    Commented Feb 6, 2010 at 12:57
  • I am assuming your database server will have at least 8G of ram, which any newly installed one may as well have these days.
    – MarkR
    Commented Feb 11, 2010 at 6:03

I start all my Linux servers out with the Ubuntu minimal CD: https://help.ubuntu.com/community/Installation/MinimalCD

I'd recommend this over Damn Small if you are actually installing the OS to the hard drive.

The minimal will install almost nothing by default, after install just apt-get install mysql-server.

If you want even less "stuff", apt-get install sysv-rc-conf. You can use this program to view everything that is automatically started by rc scripts. Be careful what you change here, but many unnecessary services can be removed.

Not sure on the error that your getting with Ubuntu, but here's my answer to the original question. If you keep getting that error you might want to ask that question separately.

  • @cory - ubuntu is great but I'm actually trying to avoid installing that version of Linux.
    – Patrick R
    Commented Feb 5, 2010 at 17:48

We use CentOs 5.x on our PE1950III's and other vintage Dells. You can do a pretty stripped down install if you need to. The nice thing about CentOs is it is essentially RedHat Enterprise. So, if RHEL can run it, CentOS can run it. Any documents or HowTos that refer to RHEL, are equally applicable to CentOS. We are running 6+ instances of MySQL 5.1, without any OS related issues.

RE: usb... device not accepting address2... BusyBox Could the service be trying to boot off of a USB device? 4 of our PE1950IIIs have internal flash drives as Citrix XenServer boot devices. These flash drives are set as the primary boot device.

  • I've removed all usb devices during boot, even the keyboard and I still get the busybox error. I definitely am not trying to boot from a usb device in this case. I'll take a close look at CentOS today. I've never tried that distro.
    – Patrick R
    Commented Feb 5, 2010 at 12:26

I've always enjoyed Gentoo for doing installs with only what I want installed.

Whether or not you get a noticeable performance boost from the fact that you are compiling the software is a big debate. I like it for the fact that it is a very very minimal install but you can easily build up on top of it.

After going through the installation you will pretty much have a system that boots to a console with minimal system tools.

You use their package management tools to compile and install additional software.

As for Ubuntu working under ESXi but not on the physical, it is because at that point Ubuntu is seeing the virtual devices created by ESXi, not the physical hardware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .