Is there a way to upgrade from windows server 2016 standard license ( no EVALUATION) to windows server 2019 using ISO method without the need to activate it in a second moment once the upgrade is over?

During the Upgrade/Installation Wizard, no prompt for a license key is shown !! and if I go further, I'm not able to keep my files/apps and the only option is to do a clean installation/upgrade. And I need to keep the previous installation !!

Both windows servers 2016-2019 got a license key.

enter image description here


3 Answers 3


what you are looking for should be described in the link on the Microsoft website:


  • Please provide the relevant steps from the link to resolve the problem.
    – Paul
    May 18, 2022 at 13:14
  • Thank you for your reply ! Where can I find a Windows server media non Evaluation version ? May 19, 2022 at 10:34
  • You can use the Evaluation media, and you can change the version from PowerShell using following command and setting the License Key: DISM /online /Set-Edition:ServerStandard /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula I suggest however to do a full raw copy of the whole disk to be safe and avoid surprises, before any upgrade. May 19, 2022 at 18:02
  • I'm already aware of this option , What I need is to do the update of the Operating System (wile keeping the files/apps to test the integrity of the already installed app/configurations on the new S.O) . I don't need to do a clean upgrade and reinstalling the previous apps/configurations ! What I'm looking for is a licensed installaion media (ISO) and not an Evaluation version ( Having already the license key to insert during the upgrade process ) Thank you for sharing , much appreciated. May 20, 2022 at 10:00

You can't use the Evaluation-ISO to upgrade. Did you buy a retail copy with DVD included? Otherwise you could grab one from MSDN, if you have an active subscription.


I had the same issue and I resolved it by mounting the ISO and changing the edition.

After copying the ISO files to a folder I ran the following:

dism /mount-wim /wimfile:c:\ISO\sources\install.wim /mountdir:c:\mount /index:2

dism /image:c:\mount /get-currentedition

dism /image:c:\mount /get-targeteditions

dism /image:c:\mount /set-edition:ServerStandard

dism /unmount-wim /mountdir:c:\mount /commit

Then I ran the setup file and it still listed eval under the options, but then it allowed me to choose to keep my files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .