This error happens even after clearing the Docker image cache:

$ docker run -it --rm mariadb:10.8.3
2022-06-15 11:28:14+00:00 [Note] [Entrypoint]: Entrypoint script for MariaDB Server 1:10.8.3+maria~jammy started.
2022-06-15 11:28:14+00:00 [ERROR] [Entrypoint]: mariadbd failed while attempting to check config
        command was: mariadbd --verbose --help --log-bin-index=/tmp/tmp.EUcxIEz4Yz
        Can't initialize timers

10.8.3 is currently the latest image on Docker Hub. The image tag is ea81af801379. This is on 64-bit Ubuntu 18.04. The server has low CPU load, 100+GB of free RAM, and terabytes of free disk space.

I have an existing database that was already touched by this version and that I wouldn't want to risk downgrading.

I have seen this issue but there's no reason that MariaDB would fail to create a thread.

How can I solve this?

4 Answers 4


The solution is to change the MariaDB version to avoid version 10.8.3, for example by forcing mariadb:10.8.2 or mariadb:10.7, or to set --security-opt seccomp=unconfined

If your Dockerfile or docker-compose are referencing mariadb:latest or mariadb:10 in Summer 2022, that's pointing to mariadb:10.8.3.

Contrary to the post by @Arno, the Docker version is not the issue. I am running Docker 20.10.17 and the problem persists.

You can also directly run with an updated security profile:

docker run --security-opt seccomp=/etc/docker/profiles-seccomp-scmp-act-trace.json

Hopefully a fix will be in the MariaDB 10.8.3 release.


  • Where do you get the file /etc/docker/profiles-seccomp-scmp-act-trace.json?
    – Nick ODell
    Jan 12 at 21:51

The issue was reported on GitHub. Upgrading Docker seems to fix it.


I had the same issue running MariaDB (latest) on Gitlab CI using Test Containers for Java.

Using the seccomp=unconfined security option - as discussed in the Github reported linked by @Arno solved this for me.

Enabling this through testcontainers-java is a bit weird, so here's the flow if readers encounter the same issue with Test Containes:

var container = new MariaDBContainer<>("mariadb:latest")
.withCreateContainerCmdModifier(cmd -> {
    var cfg = cmd.getHostConfig();
    List<String> seclist = Objects.requireNonNullElseGet(cfg.getSecurityOpts(),

This same question was asked on StackOverflow - please see my response there https://stackoverflow.com/a/72467817

To summarize, your docker version is likely < 20.10.10, which is the minimum required to use Jammy-based images. MariaDB > 10.8.2 uses Jammy, so there's a conflict there.

Upgrading docker is really the only correct option at this point - MariaDB 10.7 ends support soon on 2023-02-14, and Docker 19.03 (the release before 20.10) went EOL on 2021-07-21.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.