0

I've set up an FTPS server on an EC2 linux machine using VSFTPD, I changed the file_open_mode and local_umask in vsftpd.conf file to

local_umask=0007
file_open_mode=0777

This indeed give the rwx permissions to both the owner and the group as needed for the uploaded file (equivalent to the umask 770=777-007).

I have 2 users that connect to this ftp server, they are part of the same Linux group ftpusers.

The problem is that when user 1 uploads a file to the server, the user 2 is not able to retrieve it using curl, I get 550 error : RETR 550 : Unable to open file, same error using FileZilla.

However, if user 2 uploads a file to the ftp server with the same file permissions, user 1 is able to download it both using curl and using filezilla.

What should I do to allow each user download/retrieve the files uploaded by the other user ? I've already put them in the same usergroup.

Note: This problem is solved if I set the permissions to 777 (read, write, execute for everyone), but this seems dangerous, the ftps server will store some important files.

1 Answer 1

0

Found the solution :

I needed to use chgroup on the folders of interest to add permissions for the whole user group to access the files in these folders.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .